Page MenuHomeSolus

WIFI and ethernet connection dropping
Closed, ResolvedPublic

Description

Hi! I posted the issue on reddit 1-2 days ago.
It would seem that my WIFI would work for about half an hour before it drops and I would not even be able to connect to discord.
https://pastebin.com/q1G9YT1P
Above is my result for sudo lspci in case you need it.
Please don't hesitate to ask for more information, I'm not tech savvy so I might have missed something, sorry.
Thank you in advance!

Event Timeline

I'm also having some WiFi problems. It works for a minute then stops working but shows connected. Disabling and enabling WiFi with the keyboard button brings back WiFi, but only for a few seconds.

I have the same issues on both LAN and WiFi connections. Connection drops in between and automatically reconnects. While this is not much of an issue when simply browsing the web, it is quite problematic when video calls get interrupted due to this.

I restarted and chose kernel 4.9.64 and WiFi works as normal. It might be a bug/regression with kernel 4.9.65 ?

I booted back into kernel 4.9.65 and WiFi is working fine now. Not sure why it wasn't working properly earlier.

Can confirm on my laptop running Solus. I wondered what the issue was. I'm on the latest linux-current kernel. Disabling and re-enabling wifi through the keyboard prevents the issue for about half an hour. Seems to be extremely random. It's only been occurring for about a week now (maybe last update on Friday? IDK).

sunnyflunk added a subscriber: sunnyflunk.

How about some details of what cards you have?

inxi -N

Card-1: Intel 82579LM Gigabit Network Connection (Lewisville)
driver: e1000e
Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak]
driver: iwlwifi
baimafeima renamed this task from WIFI dropping to WIFI and ethernet connection dropping.EditedDec 4 2017, 1:37 PM

I've adjusted the title. I have disabled WiFi and only use ethernet and it drops almost every 15 minutes. I've also updated the firmware of my router to make sure there are no connectivity issues on my side.

baimafeima awarded a token.

@baimafeima try booting into the older kernel from grub and then boot back into the newer kernel and see if that helps.

Is this still an issue?

I have not had any problems with this recently.

JoshStrobl closed this task as Resolved.Jul 29 2018, 4:22 PM
JoshStrobl claimed this task.