Page MenuHomeSolus

Cannot unlock after prolonged period of screen lock/ screen blank
Closed, WontfixPublic

Description

Hi,

So when i leave office, I place machine in lock (obviously)
Next morning when I arrive, I cannot unlock. There is not even a prompt/box/place to unlock.

I am not entirely sure this is even a screensaver/lock issue, smells more like a screen-reinitialise issue.

I have 3 screens.

When I leave work, after I placed into screensaver locked, I switch off all three screens physically at their power buttons.
When I return to office next morning, the screens will not re-initialise fully.

1 screen (random) is always blank
2 screens have the default background, bu it is not 100% on each screen. Sometimes it overlaps between two screens, sometimes there semes to be multipel on one screen, half to the next.

  1. Mouse is 100% active.
  2. There is no login prompt visible anywhere

I did just try and type in password, incase it is not just visible, but that did not work.

I can drop to console (ctrl+shift+f1) and do a command: sudo loginctl terminate-session <SESSION ID> which then restores all three displays, and allows me to login

I am happy to supply any debug info at the time of the issue, which can be derived via console. Just let me know what you need.

Display card: 01:00.0 VGA compatible controller: NVIDIA Corporation GK107 [NVS 510] (rev a1) using the propriaty installed drivers (issues happens with those and the default installed drivers. I swapped to the propriety drivers after first few times this happened, to see if that helped. It did not)

Today I will not power down the screens, to see if that makes a difference.

This morning the login prompt was 100% fine. I did not power down screens as I usually do.
It is weekend, so I will leave monitors powered all weekend, and see monday if there is any issues.

Thus far this looks like a screen re-init issue, not a display manager login issue

DataDrake edited projects, added Software; removed Lacks Project.Nov 24 2017, 5:07 PM

Update:

Monday. after two days of not having had screens physically switched off, the login issue was present. So, it does not involve monitors being powered down.
Also, on Friday, the entire GUI froze once during usage. Had to ssh in from another pc, and issue the 'sudo loginctl terminate-session <SESSION ID>' command to get control back.

I am starting to suspect this is more a NVIDIA card drivers issue, as I have had this freeze occur on previous install (ubuntu) which was later solved by installing specific NVIDIA drivers.
I am proceeding to redo that install (having removed the drivers currently installed)

I think this can be closed.

Through a process of elimination I have determined teh issue is related to GPU drivers.
Having manually installed a specific set of drivers supplied via vendor website the issue is no longer happening.

ProxiBlue closed this task as Wontfix.Nov 29 2017, 1:04 AM

@ProxiBlue Which drivers did you have installed that were problematic? And which drivers did you update to?

@sunnyflunk

Driver: Linux x64 (AMD64/EM64T) Display Driver -

solus installed 387.34 (November 24, 2017)

I manually installed: 384.98 (November 2, 2017)