Page MenuHomeSolus

Triggering "disable trackpad while typing" causes screen tearing and eventual freeze
Closed, ResolvedPublic

Description

After today's sync, pressing a key while moving the trackpad will often trigger a screen tear or freeze the computer entirely. Somewhat usable video example. The display server freezes just before the end.

The laptop has an Intel iGPU and NVIDIA Optimus card. The full update list is here, sorted. Of note I think is libinput, but I don't know enough about xorg to say so with confidence.

Azphreal created this task.Nov 22 2017, 8:13 AM
DataDrake edited projects, added Software; removed Lacks Project.Nov 24 2017, 5:08 PM
DataDrake added a subscriber: DataDrake.

So, I gotta ask: What are you doing that you pressing down a key while using the touchpad?

Moving/resizing windows with super/alt + click and drag. More often it's that my palm triggers it in breaks in typing. It also seems to occur occasionally when I've just moved from the trackpad to the keyboard.

Last night it was also occurring with a desktop mouse, and was going crazy without any input at all, but I can't reproduce these.

Azphreal closed this task as Resolved.Dec 1 2017, 1:42 AM
Azphreal claimed this task.

I did a fresh reinstall of Solus from the latest ISO (was using one from February or so...) and the issue seems to be resolved.