Page MenuHomeSolus

lrzip - Long Range ZIP
Closed, ResolvedPublic

Description

Name : lrzip
Homepage / source : https://github.com/ckolivas/lrzip

A multi-thread compression utility that excels at compressing large files.
Necessary for all users that compress their archives in lrzip format.
Available in official repositories of Fedora, Ubuntu and many other distros.

Related Objects

Event Timeline

Do we have examples of files only compressed with lrzip that we need this for? Just trying to expedite the process

@josephpaul0 we would include it if you can help justify it. Ive never seen anyone use lrzip compression in the wild, so we just need examples.

So basically you are saying that Debian and RedHat maintainers are packaging software that nobody uses, because *you* don't know anybody using it ?
And of course, at the same time you don't want to create user repositories like AUR or Slackbuilds or PPA, because of course you know that nobody uses Ubuntu and ArchLinux ?

Great. Don't bother. You are too smart for me. I do not deserve to use Solus. Forget about me.

JoshStrobl closed this task as Wontfix.Dec 24 2017, 1:24 PM
JoshStrobl claimed this task.
JoshStrobl added a subscriber: JoshStrobl.

So basically you are saying that Debian and RedHat maintainers are packaging software that nobody uses, because *you* don't know anybody using it ?
And of course, at the same time you don't want to create user repositories like AUR or Slackbuilds or PPA, because of course you know that nobody uses Ubuntu and ArchLinux ?
Great. Don't bother. You are too smart for me. I do not deserve to use Solus. Forget about me.

Frankly, I'm disappointed in this sort of response. @DataDrake was asking a simple question, the usecase for providing a package in Solus, as is completely normal as part of our response to requests when assessing them alongside using our Package Inclusion Policy. Your kind of behavior and attitude is not welcome. I highly suggest you re-evaluate how you treat people that are volunteering their time, or you'll find yourself no longer engaging in this community.

DataDrake added a comment.EditedDec 24 2017, 1:39 PM

@josephpaul0 Trying to be pragmatic here. More packages means more things for us to maintain and less time to spend on other development. So I have to ask questions like this before including something. The fact of that matter is that in 2017, the most common compression formats are still zip archives and compressed tarballs. I'm not saying that no one uses lrzip. But I've also never seen it used in the wild. So I need to know that it isn't something that will get included, used by someone in for only a few months (distro hopping is a thing), and then get stuck maintaining it when no one uses it.

So basically you are saying that Debian and RedHat maintainers are packaging software that nobody uses, because *you* don't know anybody using it ?

I'm not going to include it on the premise that other distros have it because other distros have more people to continue maintaining unused software.

And of course, at the same time you don't want to create user repositories like AUR or Slackbuilds or PPA, because of course you know that nobody uses Ubuntu and ArchLinux ?

We are not allowing for user repositories for many reasons, none of which have to do with other distros. Here are a few notable ones:

  1. PPAs frequently get used over their packaged versions just because they are newer versions.
    • This isn't an issue in Solus because we are usually running much more recent versions than non-rolling distros like Debian/Ubuntu.
    • This makes it far more difficult to support users when they are running non-standard configurations.
  2. PPAs and AUR repos frequently violate the distribution rights given out by the copyright holders through license agreements.
    • Example: I am not a lawyer, but according to its license CUDA cannot legally be distributed by anyone but Nvidia or a license holder. It's SLA even prohibits us from using a Third-Party mechanism to distribute it on your behalf. I cannot say for sure why Nvidia hasn't sued over this, but they have the right to and that isn't a risk we are willing to take.

Great. Don't bother. You are too smart for me. I do not deserve to use Solus. Forget about me.

All I asked was for a single example of someone using lrzip. That could even be as a dependency for an application. Right now, all I'm finding are niche blogs from years ago talking about its advantages over existing formats.

I do admire the work that Ikey and the Solus core team have achieved.
This is a truly innovative and gorgeous Linux distro and I wish you success.
But you've got only one short life and you need help from as many people as possible, otherwise you will burn out after working so much.
I am not at all a disto hopper, but in 20 years, I've seen so many distros rise to the top of Distrowatch and then fall into pieces.
Why ? Because without a big strong, vibrant community, you will not be able to sustain the workload and your involvement, and your health, will fade away.
90% of Linux users will never bother to compile a package they need if it's not available, and they will switch back to Ubuntu / Linux Mint /Windows / Mac.
Please, accept help, put a "becoming a new contributor" document on your site, and be warm to aspring contributors. Yours truly, Joseph ;)

ikey added a comment.EditedDec 24 2017, 2:32 PM

@josephpaul0 dude we're trying to work with people, but you were asked a simple question man.

Stop being so defensive - and give us examples of stuff needing lrzip so we can justify the time that WE
spend maintaining it for others. You use examples of workload and yet you're contributing to an increased
workload and breaking of harmony by not answering the simplest question in the world.

ikey added a comment.EditedDec 24 2017, 2:34 PM

Also note you're the one dishing the shade and attitude here and accusing us of putting off newcomers - you need
to reel in the attitude and work with us. Respect works both ways.

Sorry this comment came in late. I understand that lrzip isn't widely used, but if @DataDrake asked for an example, I'm one.

My use case: the company I'm with releases software installers containing binaries for 6 different distro/version combinations.
The binaries are different but share quite many chunks of common bits.
lrzip can notice the long-range common bits and achieve better compression.
We benchmark several options, and migrated from xz to lrzip 2 (or 3) years ago.
The main drawback of lrzip is its slow speed and large memory requirement during compression, which is fine, as long as the decompression is fast and lightweight.

I personally haven't encountered lrzip files in the wild. I don't know anyone who has installed it on their ubuntu/centos systems. As a result, the above mentioned installer contains lrzip binaries for the target system.

I didn't request lrzip myself, because I have to build lrzip from source code on every system i care about, and I thought it's really niche.

@hashhsah thats a fine use case, thanks! :)

DataDrake triaged this task as Normal priority.Dec 24 2017, 2:42 PM
DataDrake moved this task from Backlog to Accepted For Inclusion on the Package Requests board.

Thanks @hashhsah :)

sunnyflunk reopened this task as Open.Dec 24 2017, 8:55 PM
sunnyflunk added a subscriber: sunnyflunk.

Making it open again, since I think that was intended

hah. missed that. Thanks @sunnyflunk

JoshStrobl removed JoshStrobl as the assignee of this task.Jan 1 2018, 8:41 PM
kyrios123 claimed this task.Jan 1 2018, 9:38 PM