Page MenuHomeSolus

LaTeXila - LaTex Editor
Closed, ResolvedPublic

Description

Homepage: http://www.xm1math.net/texmaker/index.html

The Qt toolkit (http://qt-project.org/) (version >= 4.7) and the Poppler library (http://poppler.freedesktop.org/) (version >= 0.18) are required to compile this version of Texmaker.

Can be compiled on Qt4 or Qt5

Event Timeline

ic3vaw renamed this task from AirVPN client (Eddie) - 2.11 beta - 2.10 stable to Texmaker - LaTex Editor.Sep 7 2016, 1:09 PM
ic3vaw updated the task description. (Show Details)
ic3vaw removed a project: Package Requests.
ic3vaw added a project: Package Requests.

Is there a particular reason you need TexMaker and not TexStudio or TexWorks?

@DataDrake

Just a matter of habit. If it's not possibile because it uses Qt libraries and/or it is not very much updated, there is this LaTex editor (https://wiki.gnome.org/Apps/LaTeXila): it is a LaTeX editor for the GNOME desktop distributed under GPLv3+ license.

Here the Github page: https://github.com/GNOME/latexila

DataDrake renamed this task from Texmaker - LaTex Editor to LaTeXila - LaTex Editor.Sep 7 2016, 5:26 PM
DataDrake claimed this task.
DataDrake triaged this task as Normal priority.

TeXMaker has lagged quite a lot, as their last release was almost a year ago. We generally recommend TeXStudio as a long-term replacement. I will happily package up LaTeXila as it is actively updated alongside GTK3.

bibjee added a subscriber: bibjee.Apr 28 2019, 9:41 PM

@DataDrake LaTeXila needs to be updated. It has not been updated for a long time. The project itself has been renamed to Gnome-latex. We need to update Solus so that LaTeXila is related with Gnome-Latex.
Here is the webpage that describes this: https://wiki.gnome.org/Apps/GNOME-LaTeX

In T500#149531, @bibjee wrote:

@DataDrake LaTeXila needs to be updated. It has not been updated for a long time. The project itself has been renamed to Gnome-latex. We need to update Solus so that LaTeXila is related with Gnome-Latex.
Here is the webpage that describes this: https://wiki.gnome.org/Apps/GNOME-LaTeX

It already has: R1605:3bc5fb559f3d: Update to 3.32 series and rename to gnome-latex.

We were intentionally holding it back because we were on Gnome 3.28 and newer versions were incompatible. Josh spent two weeks on the Gnome 3.32 Stack upgrade and it will be available in the next sync.

@DataDrake Marvelous. Thanks.