Page MenuHomeSolus

Touchpad randomly freezes, requires forced shut down
Closed, InvalidPublic

Description

On my Dell Inspiron 15R laptop, lately I've noticed that sometimes my touchpad stops responding and I have to restart to fix this. All I can do is press the power button and press Enter which shuts down, but if I press Tab while the shut down dialog is open, I can't escape out of it and pressing the power button again resets the countdown to auto shut down. Then I have to hold down the power button to force it off. I'm still able to open the menu using the Windows key and close Firefox using Ctrl+Q.

Event Timeline

Could you please try again after the next sync ?
The following update might fix your problem : 109243a658a7

This problem is most likely fixed since I can once again press the battery and touchpad buttons and they work fine, thanks!
I'll keep this open and comment again if it happens again.

mate-user added a comment.EditedOct 31 2017, 7:49 PM

This happened to me again yesterday, I had to force shut down with the power button. Maybe it's just my old laptop malfunctioning. Sometimes the slightest movement can cause it to die suddenly!

This just happened to me now and I fixed it somehow by moving my right and left index fingers at the same time randomly around the touchpad ! Maybe the pointer freezes because I touched the touchpad with two fingers simultaneously in a specific way which caused it to freeze until that's done again to unfreeze it.

This has happened to me a few times before too and I also assumed it was because of my old laptop, maybe not though...

GreenMartian added a subscriber: GreenMartian.EditedNov 1 2017, 12:17 AM

You may wish to check if your machine is using Nvidia graphics. Type inxi -G into a terminal window.

If yes, you would want to install nvidia-glx-driver-current if your running the current kernel, or nvidia-glx-driver if your running the lts kernel. You can check your running kernel by typing uname -r into a terminal window.

Reboot

mate-user added a comment.EditedNov 1 2017, 9:55 AM

My laptop uses Intel graphics and has the 4.9 LTS kernel.

Mine is also using Intel graphics but with the latest kernel instead

DataDrake edited projects, added Hardware; removed Lacks Project.Nov 2 2017, 3:23 PM

We've had a few libinput updates since. Is anyone still experiencing this?

mate-user closed this task as Resolved.Mar 18 2018, 8:34 PM
mate-user claimed this task.

From the comments here, this happened to me last on 31st October 2017 but I remember it happened to me recently in the last month where I was sitting in a study area and wondering if I should ask to borrow someone's mouse to move the pointer. In the end I just forced shut down.
I'll close this issue, but if it happens again, I'll leave a comment here.
If it happens to anyone else, please leave a comment or reopen this task.

mate-user reopened this task as Open.EditedApr 6 2018, 11:10 AM

This happened to me again a few minutes ago. I was scrolling on Facebook and the pointer froze. Right and left clicking still worked, but could not move using the touchpad. I was not plugged into the power outlet, which may have something to do with it.

If you have stuff like tlp installed, try removing it

I don't have TLP installed.

DataDrake removed mate-user as the assignee of this task.Jun 17 2018, 12:02 AM
DataDrake triaged this task as Needs More Info priority.Oct 16 2018, 5:24 PM

Is this still an issue?

I've bought a new laptop, done a fresh install of Solus 3 Mate, and I have not experienced this issue.
But it may still be affecting @waddon1 and others.

DataDrake closed this task as Invalid.Oct 16 2018, 5:51 PM

Then I'm going to mark this as invalid for now unless someone else reports the issue is still around.