Page MenuHomeSolus

Two-sided printing layout is not working properly
Closed, ResolvedPublic

Description

Hi,

I'm able to print in Two-sided configuration, but "Long Edge" and "Short Edge" modes are behaving as "Short Edge" mode.
I'm not able to print in Two-sided Long Edge mode.

Some context:
Until now, I was not able to use my printer. I started to be able to print after the driverless printer improvements.

Printer: Brother DCP-L2520DW

Related Objects

arturjpv created this task.Oct 21 2017, 9:39 AM
JoshStrobl edited projects, added Software; removed Lacks Project.Oct 26 2017, 1:25 AM

I can confirm this issue with my brother printer (HL-L2340DW). Also if it helps, this appears to only be a Solus issue as I tested Fedora and was able to print normally.

DataDrake triaged this task as Needs More Info priority.Oct 8 2018, 12:05 PM
DataDrake added a subscriber: DataDrake.

Is this still an issue after the latest updates?

After the latest updates I am no longer experiencing issues printing two sided. Thanks for the great work!

JoshStrobl closed this task as Resolved.Oct 11 2018, 5:57 PM
JoshStrobl claimed this task.

Hello,

Sorry but this is still an issue for me. I did a quick test today and everything seems to be working as before. For my printer (Brother DCP-L2520DW), long edge two side printing is still behaving as short edge.

I will do a more detailed test tomorrow, like removing the auto added printer, adding one choosing the driver and changing settings from the printer and from the document viewer among others just in case.

This is working after @Girtablulu's help provided in T83: Brother Drivers