Page MenuHomeSolus

Virtualbox is not running after latest updates
Closed, ResolvedPublic

Description

Hello,

After latest updates on friday, Virtualbox is not running. I have tried to install again and it is still failing. Would you help please?

bash-4.3$ sudo sh VirtualBox-5.1.28-117968-Linux_amd64.run
Password:
Verifying archive integrity... All good.
Uncompressing VirtualBox for Linux installation.............
VirtualBox Version 5.1.28 r117968 (2017-09-13T09:24:07Z) installer
Removing previous installation of VirtualBox 5.1.28 r117968 from /opt/VirtualBox
Installing VirtualBox to /opt/VirtualBox
Python found: python, installing bindings...
Created symlink /etc/systemd/system/multi-user.target.wants/vboxdrv.service → /usr/lib/systemd/system/vboxdrv.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxballoonctrl-service.service → /usr/lib/systemd/system/vboxballoonctrl-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxautostart-service.service → /usr/lib/systemd/system/vboxautostart-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxweb-service.service → /usr/lib/systemd/system/vboxweb-service.service.
vboxdrv.sh: failed: Look at /var/log/vbox-install.log to find out what went wrong.

There were problems setting up VirtualBox. To re-start the set-up process, run

/sbin/vboxconfig

as root.

VirtualBox has been installed successfully.

You will find useful information about using VirtualBox in the user manual

/opt/VirtualBox/UserManual.pdf

and in the user FAQ

http://www.virtualbox.org/wiki/User_FAQ

We hope that you enjoy using VirtualBox.

The installation log file is at /var/log/vbox-install.log.
bash-4.3$ uname -a
Linux kizilyildiz 4.13.7-27.current #1 SMP Sat Oct 14 16:26:24 UTC 2017 x86_64 GNU/Linux

Event Timeline

saygili created this task.Oct 17 2017, 7:36 AM

What does the content of /var/log/vbox-install.log say?

Hi,

Here it is:

bash-4.3$ cat /var/log/vbox-install.log

VirtualBox 5.1.28 r117968 installer, built 2017-09-13T09:24:07Z.

Testing system setup...
Removing previous installation of VirtualBox 5.1.28 r117968 from /opt/VirtualBox

vboxdrv.sh: Stopping VirtualBox services.
vboxdrv.sh: Building VirtualBox kernel modules.
make KBUILD_VERBOSE=1 SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 CONFIG_MODULE_SIG= -C /lib/modules/4.13.7-27.current/build -j4 modules
make[1]: warning: -jN forced in submake: disabling jobserver mode.
/bin/sh: ./scripts/gcc-goto.sh: No such file or directory
Makefile:826: scripts/Makefile.ubsan: No such file or directory
make[1]: * No rule to make target 'scripts/Makefile.ubsan'. Stop.
make:
* [Makefile:305: vboxdrv] Error 2
bash-4.3$

Looks like you're missing a few packages.

Have you tried following the guide to installing Virtualbox?

@saygili are you on the current or on the lts kernel ?

Hi,

It is not fresh install. This happened after package upgrade. Because of this, I am trying to reinstall. Before upgrade of packages it was working.

Murat

Hi,
It is not fresh install. This happened after package upgrade. Because of this, I am trying to reinstall. Before upgrade of packages it was working.
Murat

I just tested following the guide, and installing Virtualbox version 5.1.30. Perhaps there are new dependencies, I'd still suggest you install the packages listed on the Solus guide.

Hello,

Problem solved.

bash-4.3$ sudo eopkg install linux-current-headers
Password:
The following package(s) are already installed and are not going to be installed again:
linux-current-headers
No packages to install.
bash-4.3$ sudo eopkg it -c system.devel
The following package(s) are already installed and are not going to be installed again:
abireport autoconf automake binutils binutils-libs bison bison-devel catbox cmake db5-devel diffstat diffutils fakeroot file-devel
flex flex-devel g++ gcc gettext-devel gfortran glib2-devel glibc-devel gmp-devel gobject-introspection-devel intltool libffi-devel libgcrypt-devel libgpg-error-devel
libtool-devel libxml2-devel linux-headers m4 make meson mpc-devel mpfr-devel nano nasm ncurses-devel openssl-devel pam-devel patch
perl-xmlparser pkg-config polkit-devel python-dbus-devel python-devel quilt readline-devel spidermonkey-devel texinfo util-linux-devel xz-devel ypkg zlib-devel
Total size of package(s): 4.00 KB
Downloading 1 / 1
Package libgudev-devel found in repository Solus
libgudev-devel-232-3-1-x86_64.eopkg (4.0 KB)100% 1.15 MB/s [00:00:00] [complete]
Installing 1 / 1
libgudev-devel-232-3-1-x86_64.eopkg [cached]
Installing libgudev-devel, version 232, release 3
Extracting the files of libgudev-devel
Configuring libgudev-devel package
Configured libgudev-devel
Installed libgudev-devel
bash-4.3$ sudo sh VirtualBox-5.1.28-117968-Linux_amd64.run
Verifying archive integrity... All good.
Uncompressing VirtualBox for Linux installation.............
VirtualBox Version 5.1.28 r117968 (2017-09-13T09:24:07Z) installer
Removing previous installation of VirtualBox 5.1.28 r117968 from /opt/VirtualBox
Installing VirtualBox to /opt/VirtualBox
Python found: python, installing bindings...
Created symlink /etc/systemd/system/multi-user.target.wants/vboxdrv.service → /usr/lib/systemd/system/vboxdrv.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxballoonctrl-service.service → /usr/lib/systemd/system/vboxballoonctrl-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxautostart-service.service → /usr/lib/systemd/system/vboxautostart-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxweb-service.service → /usr/lib/systemd/system/vboxweb-service.service.
vboxdrv.sh: failed: Look at /var/log/vbox-install.log to find out what went wrong.

There were problems setting up VirtualBox. To re-start the set-up process, run

/sbin/vboxconfig

as root.

VirtualBox has been installed successfully.

You will find useful information about using VirtualBox in the user manual

/opt/VirtualBox/UserManual.pdf

and in the user FAQ

http://www.virtualbox.org/wiki/User_FAQ

We hope that you enjoy using VirtualBox.

The installation log file is at /var/log/vbox-install.log.
bash-4.3$

It seems new package introduced with latest kernel which is l**ibgudev-devel-232-3-1-x86_64.eopkg [cached].

BR

Murat

Sorry,

still same :(

Could you try with the latest VirtualBox? It gave me an error as well, but starts fine regardless.

Hi, I tried 5.1.30 and same. Running virtualbox does not give error. Startting virtual machine has problem.

could you paste the output of this command please : eopkg info linux-current | head -n2; uname -r

Hello,

bash-4.3$ eopkg info linux-current | head -n2; uname -r
Installed package:
Name : linux-current, version: 4.13.7, release: 27
4.13.7-27.current
bash-4.3$

BR
Murat

Delete /opt/VirtualBox then install vritualbox again.

Hi,

Same. Here is the output.

bash-4.3$ sudo sh VirtualBox-5.1.30-118389-Linux_amd64.run uninstall
Verifying archive integrity... All good.
Uncompressing VirtualBox for Linux installation.............
VirtualBox Version 5.1.30 r118389 (2017-10-16T10:09:41Z) installer
VirtualBox 5.1.30 r118389 has been removed successfully.
bash-4.3$ ls /opt/
bash-4.3$ sudo sh VirtualBox-5.1.30-118389-Linux_amd64.run
Verifying archive integrity... All good.
Uncompressing VirtualBox for Linux installation.............
VirtualBox Version 5.1.30 r118389 (2017-10-16T10:09:41Z) installer
Installing VirtualBox to /opt/VirtualBox
Python found: python, installing bindings...
Created symlink /etc/systemd/system/multi-user.target.wants/vboxdrv.service → /usr/lib/systemd/system/vboxdrv.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxballoonctrl-service.service → /usr/lib/systemd/system/vboxballoonctrl-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxautostart-service.service → /usr/lib/systemd/system/vboxautostart-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxweb-service.service → /usr/lib/systemd/system/vboxweb-service.service.
vboxdrv.sh: failed: Look at /var/log/vbox-install.log to find out what went wrong.

There were problems setting up VirtualBox. To re-start the set-up process, run

/sbin/vboxconfig

as root.

VirtualBox has been installed successfully.

You will find useful information about using VirtualBox in the user manual

/opt/VirtualBox/UserManual.pdf

and in the user FAQ

http://www.virtualbox.org/wiki/User_FAQ

We hope that you enjoy using VirtualBox.

The installation log file is at /var/log/vbox-install.log.

Did you try to do what the message says ?

yes. same. this is related to new kernel build I guess.

Weird... I use virtualbox every day without any issue (with the lts kernel on the host and the current kernel on the guests)

I am also using it. It happened after the latest upgrade. There is something wrong in this. I opened a discussion in G+ and 4 people also having same problem.

Hi,

I have freshly installed solus and now it works. I do not know it seems something happened on last update. But it is ok now.

Murat

I'll try to package virtualbox someday...
Just started reading the build instruction...

bja_au added a subscriber: bja_au.Oct 22 2017, 2:34 AM

G'day - I am having the same problem - stuck on kernel version 4.13.5-24.current - both of the new kernels since then (4.13.7-27 & 4.13.8-28) have produced the above outcomes :(

Also had the same problem with the latest kernel (4.13.8-28) and wasn't sure how to downgrade to a specific older version of the current. Installed the lts kernel and managed to get virtualbox 5.1.30 to install properly.

@Justin Can you look into this, seeing as you were the last to update the VirtualBox doc (I'm assuming you tested against -current, right?). Thanks!

FYI - I upgraded VBox to version 5.2.0 but the same problem persisted - looks like it's a Solus problem :(

Again reverting to kernel 4.13.5-24.current fixes the problem

sunnyflunk added a subscriber: sunnyflunk.EditedOct 22 2017, 6:26 AM

I just tried 5.2.0 with the instructions. Worked without an issue once I got install the linux-current-headers that matched the running kernel.

$ sudo sh VirtualBox-5.2.0-118431-Linux_amd64.run
Password: 
Verifying archive integrity... All good.
Uncompressing VirtualBox for Linux installation.............
VirtualBox Version 5.2.0 r118431 (2017-10-18T06:14:42Z) installer
Removing previous installation of VirtualBox 5.2.0 r118431 from /opt/VirtualBox
Installing VirtualBox to /opt/VirtualBox
Python found: python, installing bindings...
Created symlink /etc/systemd/system/multi-user.target.wants/vboxdrv.service ��� /usr/lib/systemd/system/vboxdrv.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxballoonctrl-service.service ��� /usr/lib/systemd/system/vboxballoonctrl-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxautostart-service.service ��� /usr/lib/systemd/system/vboxautostart-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxweb-service.service ��� /usr/lib/systemd/system/vboxweb-service.service.

VirtualBox has been installed successfully.

You will find useful information about using VirtualBox in the user manual
  /opt/VirtualBox/UserManual.pdf
and in the user FAQ
  http://www.virtualbox.org/wiki/User_FAQ

We hope that you enjoy using VirtualBox.

$ uname -a
Linux crimson-brix 4.13.8-28.current #1 SMP Wed Oct 18 15:53:04 UTC 2017 x86_64 GNU/Linux

p.s. any ideas how to purge this from my system? xD

Reinstall the headers:

sudo eopkg install --reinstall linux-current-headers

Validate it through: eopkg check linux-current-headers should come back OK

Such problems are almost always caused by a mismatch between the kernel version and the kernel header version.
I think the recent segfault problem that occurred with clr-boot-manager did prevent the kernel to be updated on some machines meaning the headers are more recent than the kernel.

Ahha! Thanks @sunnyflunk ...

sudo eopkg check linux-current-headers returned a whole mess of missing files (I assume pretty much the whole lot):

Checking integrity of linux-current-headers    Broken
Missing file: /usr/src/linux-headers-4.13.8-28.current/Documentation/.gitignore
Missing file: /usr/src/linux-headers-4.13.8-28.current/Documentation/00-INDEX
Missing file: /usr/src/linux-headers-4.13.8-28.current/Documentation/ABI/README
Missing file: /usr/src/linux-headers-4.13.8-28.current/Documentation/ABI/obsolete/proc-sys-vm-nr_pdflush_threads
...
etc...

Do we think there was an issue with the update where linux-current and linux-current-headers were updated at the simultaneously (does the headers package have to match the running kernel at install time)? According to eopkg history the correct package was upgraded to:

Operation #44: upgrade
Date: 2017-10-21 09:32

    * linux-current is upgraded from 4.13.7-27-1-x86_64 to 4.13.8-28-1-x86_64 with delta.
    * linux-current-headers is upgraded from 4.13.7-27-1-x86_64 to 4.13.8-28-1-x86_64 with delta.

Working fine now after the sudo eopkg install --reinstall linux-current-headers thanks!

EXCELLENT! Thanks sunnyflunk - solved the problem - all works fine now

@saygili can this now be resolved?

Yes please.

Justin closed this task as Resolved.Oct 24 2017, 3:17 AM
Justin claimed this task.