Page MenuHomeSolus

GitKraken crashes on opening
Closed, ResolvedPublic

Description

Fresh Solus 3 installation, no updates available.
Installed GitKraken from software center.
Opening it from the Menu doesn't do anything.
Opening it from Terminal by gitkraken gives next output (notice bad symbols - they're supposed to be Cyrillic Russian, AFAIK):

> gitkraken
Node started time: 1508088356127
libcurl-gnutls.so.4: невозможно открыть разделяемый объектный Ñ
                                                                                                    айл: Нет такого Ñ
         айла или каталога
Error: libcurl-gnutls.so.4: невозможно открыть разделяемый объектный Ñ
                                                                                                           айл: Нет такого Ñ
                айла или каталога
    at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:173:20)
    at Object.Module._extensions..node (module.js:598:18)
    at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:187:18)
    at Module.load (module.js:488:32)
    at tryModuleLoad (module.js:447:12)
    at Function.Module._load (module.js:439:3)
    at Module.require (module.js:498:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/usr/share/gitkraken/resources/app.asar/node_modules/nodegit/dist/nodegit.js:11:12)
    at Object.<anonymous> (/usr/share/gitkraken/resources/app.asar/node_modules/nodegit/dist/nodegit.js:1025:3)
    at Module._compile (module.js:571:32)
    at Object.Module._extensions..js (module.js:580:10)
    at Module.load (module.js:488:32)
    at tryModuleLoad (module.js:447:12)
    at Function.Module._load (module.js:439:3)
    at Module.require (module.js:498:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/usr/share/gitkraken/resources/app.asar/src/appBootstrap/upgradeScripts/versionScripts/v1_5_0.js:7:17)
    at Object.<anonymous> (/usr/share/gitkraken/resources/app.asar/src/appBootstrap/upgradeScripts/versionScripts/v1_5_0.js:298:3)
    at Module._compile (module.js:571:32)
    at Object.Module._extensions..js (module.js:580:10)
    at Module.load (module.js:488:32)
    at tryModuleLoad (module.js:447:12)
    at Function.Module._load (module.js:439:3)
    at Module.require (module.js:498:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/usr/share/gitkraken/resources/app.asar/src/appBootstrap/upgradeScripts/versionScripts/index.js:5:28)
    at Object.<anonymous> (/usr/share/gitkraken/resources/app.asar/src/appBootstrap/upgradeScripts/versionScripts/index.js:14:3)
    at Module._compile (module.js:571:32)
    at Object.Module._extensions..js (module.js:580:10)
    at Module.load (module.js:488:32)
    at tryModuleLoad (module.js:447:12)
    at Function.Module._load (module.js:439:3)
    at Module.require (module.js:498:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/usr/share/gitkraken/resources/app.asar/src/appBootstrap/upgradeScripts/index.js:7:24)
    at Object.<anonymous> (/usr/share/gitkraken/resources/app.asar/src/appBootstrap/upgradeScripts/index.js:43:3)
    at Module._compile (module.js:571:32)
    at Object.Module._extensions..js (module.js:580:10)
    at Module.load (module.js:488:32)
    at tryModuleLoad (module.js:447:12)
    at Function.Module._load (module.js:439:3)
    at Module.require (module.js:498:17)
    at require (internal/module.js:20:19)
    at App.module.exports.app.on (/usr/share/gitkraken/resources/app.asar/src/appBootstrap/main.js:174:5)
    at emitTwo (events.js:111:20)
    at App.emit (events.js:191:7)

Event Timeline

nezorflame updated the task description. (Show Details)
nezorflame updated the task description. (Show Details)

Unable to reproduce, GitKraken is opening up fine here. I suggest moving your GitKraken config folder and seeing if that resolves the issue.

LIke I said, fresh install - I don't even have .gitkraken folder in home directory.

Deleted .gitconfig just in case - no luck.

I don't know if I should be posting this here, but I also got this output and I was able to fix it and get gitkraken to launch by installing curl-gnutls

michaelkisiel added a comment.EditedOct 19 2017, 1:28 PM

Also fresh install of solus 3 here and gitkraken from sc. Gettin exactly same output with first lines being:

libcurl-gnutls.so.4: cannot open shared object file: No such file or directory
Error: libcurl-gnutls.so.4: cannot open shared object file: No such file or directory
    at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:173:20)
...

But iPhantomMonkey's hint helps definitely.

Yep, I can confirm that installing curl-gnutls fixes the issue.

JoshStrobl changed the task status from Open to In Progress.Oct 19 2017, 10:39 PM
JoshStrobl closed this task as Resolved.
JoshStrobl claimed this task.