Page MenuHomeSolus

java 9
Closed, DuplicatePublic

Description

java 9
http://www.oracle.com/technetwork/java/javase/downloads/index.html
we have only openjdk and its 8, if devs want to migrate to 9v need to download it manually
nope, its not opensource
http://www.oracle.com/technetwork/java/javase/downloads/jdk9-downloads-3848520.html

Related Objects

Duplicates Merged Here
T5650: OpenJDK 9

Event Timeline

Nojpg created this task.Oct 14 2017, 12:22 AM
Nojpg updated the task description. (Show Details)
DataDrake added a subscriber: DataDrake.EditedOct 14 2017, 12:31 AM

We cannot legally ship any version of the Oracle JDK. Their license expressly prohibits redistribution. I plan on working on Java 9 support in the coming months, but that will /not/ replace the openjdk-8 package and we do not plan on retiring OpenJDK 8 until it is no longer supported.

You are welcome to follow the instructions for installing the Oracle JDK as described here:
https://solus-project.com/articles/software/java/en/

As this more closely aligns with a request for OpenJDK 9, I will be merging it into the related task.

DataDrake closed this task as a duplicate of T4578: openjdk-9.Oct 14 2017, 12:33 AM

As this more closely aligns with a request for OpenJDK 9, I will be merging it into the related task.

Ty, at least onpenjdk9 will be great.

waddon1 closed this task as a duplicate of T5650: OpenJDK 9.Jan 28 2018, 1:44 PM
waddon1 merged a task: T5650: OpenJDK 9.
waddon1 added a subscriber: waddon1.