Page MenuHomeSolus

Plasma Testing ISO
Closed, ResolvedPublic

Tokens
"Pterodactyl" token, awarded by Sondeluz."Love" token, awarded by selfus."Love" token, awarded by taohansen."Love" token, awarded by catman1900."Love" token, awarded by supernova."Like" token, awarded by EQLucky."100" token, awarded by freddiaN."Like" token, awarded by darkben."Love" token, awarded by waddon1."Like" token, awarded by trixon."Like" token, awarded by Chuck."100" token, awarded by joebonrichie."Party Time" token, awarded by livingsilver94."Like" token, awarded by baimafeima."Party Time" token, awarded by marcoraz."Like" token, awarded by kyrios123."Love" token, awarded by whatever."Like" token, awarded by blaz."Cup of Joe" token, awarded by mcritchlow."Like" token, awarded by folcred."Dat Boi" token, awarded by ikey."Party Time" token, awarded by JoshStrobl."Love" token, awarded by feskyde."Like" token, awarded by Elvanex."Like" token, awarded by Justin.
Assigned To
Authored By
sunnyflunk, Oct 11 2017

Description

The time is about right to have a testing medium available. First a couple of items need to be done before testing is worthwhile. The initial ISO will be fairly sparse of configuration changes and is for testing changes that would improve the experience. Not for resale or installation.

Work will start after next sync and KF5 5.39 release

  • QT 5.9.2
  • KF5 5.39 (add qqc2-desktop-style)
  • Plasma 5.11 (add drkonqi)
  • KDE Apps 17.08.2
  • Push a couple of app updates after full stack rebuild sddm/partitionmanager

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
sunnyflunk triaged this task as Unbreak Now! priority.
JoshStrobl updated the task description. (Show Details)
feskyde added a subscriber: feskyde.
blaz awarded a token.Oct 11 2017, 5:17 AM
blaz added a subscriber: blaz.
whatever added a subscriber: whatever.
marcoraz added a subscriber: marcoraz.
pokgak added a subscriber: pokgak.Oct 11 2017, 10:44 AM
oft added a subscriber: oft.Oct 11 2017, 12:14 PM
th108 added a subscriber: th108.Oct 11 2017, 2:47 PM
freddiaN added a subscriber: freddiaN.
EQLucky added a subscriber: EQLucky.
Justin added a subscriber: Justin.Oct 13 2017, 1:28 AM
j-hdt added a subscriber: j-hdt.Oct 13 2017, 8:34 PM
supernova added a subscriber: supernova.

So would this ISO have KDE apps or GNOME apps? and would it have KDE Wallet? or KDE PIM? will it be stock KDE, or Solus styled, or a hybrid of KDE but GTK apps?

STiAT added a subscriber: STiAT.Oct 14 2017, 9:25 PM

Adding myself. Said I'll test when it's published, will do so.

taohansen added a subscriber: taohansen.
selfus added a subscriber: selfus.
Sondeluz added a subscriber: Sondeluz.
sunnyflunk changed the task status from Open to In Progress.Oct 16 2017, 12:36 PM
sunnyflunk added a subscriber: ikey.

I've established a first build for a testing ISO. This shouldn't be taken remotely as what will be shipped, it provides something you can whack on a USB and boot into to play around with. It also includes several debug packages, for well debugging [if it's not clear, this is a testing ISO and pretty bad for installing from and cuts your feedback from testing as you are no longer testing the changes made], as there's a crash in akonadi/korganizer so it can be fully reproduced and backtraced. If you know what you're doing, then looking at that would be super (just try to add anything to the calendar to reproduce).

This ISO is to provide feedback on what settings you would change, what apps are missing from the repos (relevant ones only!!) so that a default configuration can be fleshed out (plus bug hunting). More ISOs will produced as and when needed as this provides the clean environment that requires testing.

@ikey feel free to whack an ISO at the patrons once you check it boots (I haven't had time to validate one from the repo) but have made a few tweaks to the defaults.

jakes added a subscriber: jakes.Oct 23 2017, 2:53 PM
folcred added a subscriber: folcred.EditedOct 23 2017, 11:27 PM

Is the Akonadi bug still a problem @sunnyflunk? I have it working on my install. Had to install Mariadb-server and do an 'update-mime-database' on the /usr/share/mime folder.

On the test iso all I had to do was run the mime update to get it working.

Seems the default settings are for MySql, and while akonadi is suppose to be able to work with sqlite3, I just couldn't get it to work on my installed Plasma. Stopped the akonadi server, deleted all the user configs (~/.config/akonadi & ~/.local/share/akonadi), installed mariadb & mariadb-server. Restarted akonadi, but it was still crashing with an error in ~/.xsessions-errors, "Wrong payload type (requested: sp(0)<QByteArray>". A little googling showed it was a mime problem, so ran the update. Tried that on the testing iso and it worked there too. It's all working now, calendar, to-dos, journal, etc. Reboot the system and it's still working, everything's there.

Have no interest in kmail or any of that, so I haven't tested them. But hope this helps.

BTW, if there's somewhere else you'd rather users report things for Plasma, please let me know.

@folcred indeed it was still an issue (and a full blocker at that). I did find though that building it with clang resulted in it working without the mime update oddly enough (though maybe not correctly). This could have an impact on other parts of the system, so will definitely follow it up.

If you have solid solutions like this, you can report it anywhere you like!

@sunnyflunk, if it helps, this is the link that put me on to the mime problem. It mentions a conflict between XDG_DATA_DIRS and ld.conf, so maybe that's why clang-built ones work?

So while we wait for this treasure, can you give us instructions to install Plasma on our existing Solus install?

This comment was removed by sudopluto.

@GNOME-IS-LIFE, you can install if from the software center, just grab both KDE Desktop and KDE Desktop - Core System. But be warned, there will be problems. None of the current isos (Budgie, Gnome, MATE) were designed to accommodate Plasma, so there will be issues. Start-up daemons conflict, power management may or may not work... Plasma's default single-click won't work... themeing can be a problem... etc., etc.

If you know your way around a Linux system and know Plasma/Qt fairly well, all these issues are repairable. If not, I'd recommend waiting for a Plasma iso. I don't think it will be much longer, given the state it's in now.

Having said that, Plasma works great on Solus. I've been using it as my daily driver for about 6 weeks or more now. Once I got the problems I mentioned cured, it's been flawless. Of course, when a Plasma iso does come out, it won't have any of the problems installing on top of Budgie/Gnome/MATE has now, the iso will be built for it. That's why installing it on top of one of the others really doesn't help with bug hunting, most of the problems encountered aren't actually bugs, they're conflicts with the existing DE environment.

sunnyflunk closed this task as Resolved.Oct 27 2017, 2:35 AM

If you know your way around a Linux system and know Plasma/Qt fairly well, all these issues are repairable. If not, I'd recommend waiting for a Plasma iso. I don't think it will be much longer, given the state it's in now.

I haven't even been able to validate ssh/gpg unlocking due to the corruption from gnome-keyring.

Anyway, this task has long been completed. Likely Monday will provide the things I require to be tested/fixed prior to an installable ISO (such as working installer since it is not coinciding with a Solus release)

@sudopluto Ha well when I originally made this account, GNOME was life! but now, KDE is love! (Budgie is also good, but KDE has blur and global menu!!)

PooLee added a subscriber: PooLee.Oct 29 2017, 10:59 AM
Unknown Object (User) added a subscriber: Unknown Object (User).Jan 26 2018, 12:33 PM

@folcred Could that be the reason I can't start KDE? 'Cause my main DE is Budgie but I've installed Plasma and all that is needed in order to launch a Plasma session and I have set SDDM as my DM (which works great btw), but Plasma fails to start. All it does is give me a black screen after choosing the Plasma session in SDDM.

I really can't say @Vistaus, I'm not familiar with SDDM. I use LightDM myself. I don't think the display manager would make a difference, but I don't know for sure. It shouldn't.

There's some possibilities that should be noted:

  1. Plasma takes a lot longer to load up than it use to, so my guess is it's doing more behind the scenes, though I haven't bothered to find out what. This is a Plasma issue, not Solus. There's been quite a bit of talk about it from users on forums across the web.
  2. When you start Plasma for the first time on a new install, it does a lot of setup and configuration, which adds to the startup delay. It should start, but waiting a minute or more, especially on a slower spinning drive, isn't that unusual.

Assuming you're giving it enough time to have configured it's user account defaults (and not gotten impatient and killed X to restart), the only thing I can suggest is checking the logs. There should be something in the journal that would tell why it's not starting, or what is failing/missing.

Unknown Object (User) added a comment.Jan 26 2018, 2:15 PM

@folcred Thanks. I also can't get Plasma to start from LightDM.

  1. Plasma may take longer to start, but even after several minutes it's still all black for me, the desktop doesn't ever load.
  2. I have an SSD, but even so, it doesn't load even after several minutes of looking at the black screen.

What log should I check?

From a terminal run sudo journalctl -r. Normally you would just use journalctl to show your user's logs, but running as root will ensure you see all the logs. The "-r" switch tells journalctl to start from the last entries in the logs instead of the first. Depending on how much has gone on since you last tried, you may still have to scroll through a bit. You're mainly looking for errors from the DM, Plasma or Kwin, but any errors are worth noting.

If you want to learn more about the journal and journalctl, man journalctl will give you a lot of information.

I don't understand this one at all @Vistaus. It appears that SDDM is killing the X server before Plasma even starts.
https://s13.postimg.org/jbkzf0s07/IMG_20180127_142808.jpg

In the first five lines things are pretty normal, then SDDM removes the main display and kills the X server! All the rest of the messages are things trying to connect to X which isn't there anymore. I've seen similar errors when X didn't start, but I've never seen a DM start and then kill the X server during a login.

In many of the other images there's lines that look like a bunch of Gnome/Budgie services are starting, which is blocking KDE's services, access to dbus for one.

How did you install Plasma? Did you do sudo eopkg install -c desktop.kde? It does seem like some things are missing too.

Also, have you tried from a cold boot? Power off and start again? Everything should be cleared from memory on a reboot, but with some hardware that doesn't always happen. A cold start will ensure memory is cleared.
I would suggest:

  • If you haven't already, install desktop.kde
  • Switch back to lightDM. You said earlier you tried it, so I'll assume you know how to switch display managers.
  • With that done, do a cold boot. Power off, wait about 10 seconds, then power on.

If none of this helps, I'd file a bug report. These are the kinds of things sunnyflunk needs to know about before Plasma is considered ready. I'd probably file a bug report against SDDM anyway. I see no reason for it to be killing X during login.

Unknown Object (User) added a comment.Jan 28 2018, 12:18 PM

@folcred Thank you so much! I've reinstalled KDE and it now finally works. Not sure what was wrong, maybe something got borked during the previous install but it's solved now. Plasma on Wayland isn't working though. I know it's experimental, but still. But the X11 session is working great now. Thanks again! :-)