Page MenuHomeSolus

Google Play Music Desktop Player
Closed, ResolvedPublic

Event Timeline

yattaah created this task.Sep 4 2016, 6:30 PM
yattaah added a project: Package Requests.
yattaah edited subscribers, added: Triage Team; removed: Package Requests.
JoshStrobl closed this task as Wontfix.Sep 4 2016, 8:08 PM
JoshStrobl claimed this task.
JoshStrobl added a subscriber: JoshStrobl.

You already can use Google Play Music via Nuvola Player.

I know but the performance via Nuvola Player is quite bad and it has several graphical glitches (it is even still using flash...I mean...come on...).
GPMDP on the other hand runs great, has more features (last.fm tracking, mini player, equalizer etc.) and is well received by Google Play Music users.

JoshStrobl reopened this task as Open.Sep 4 2016, 9:01 PM
JoshStrobl triaged this task as Normal priority.

Well fine then :P

JoshStrobl changed the task status from Open to In Progress.Oct 29 2016, 8:52 PM
JoshStrobl closed this task as Wontfix.Nov 12 2016, 2:12 AM

Closing as WONTFIX because it falls on its face during build by creating recursive directories to the point it is actually creates a ENAMETOOLONG.

Will this be dropped forever? I've made a issue thread on github. link I did state that all the requirements were used, sunnyflunk told me it was.

We use nodejs 6.9.1 LTS, which is the recommended nodejs version (according to the nodejs site), as well as the latest NPM for that version. It isn't "outdated".

JoshStrobl reopened this task as Open.Nov 16 2016, 6:23 PM

Grumbles. I'll update us to latest current. But it isn't going in until I validate it against existing software. I'll reopen this.

JoshStrobl changed the task status from Open to In Progress.Nov 16 2016, 6:50 PM

Upgraded our nodejs to 7.1.0 current (despite ya know, the LTS branch which should have been tested against by upstream, but whatever): https://git.solus-project.com/packages/nodejs/commit/?id=3b2a07bc6955c3ead15964f3a682517193eba50b

Gonna mark this as In Progress again and see about landing it.

JoshStrobl closed this task as Wontfix.Nov 16 2016, 7:08 PM

Yea no, still the same issue. On latest nodejs and npm. Closing as an upstream issue.

JoshStrobl reopened this task as Open.Nov 17 2016, 7:23 AM

Upstream issue allegedly resolved as of https://github.com/MarshallOfSound/Google-Play-Music-Desktop-Player-UNOFFICIAL-/commit/031b5df18efbd4f8357d4064fcf02bb63cb9c71b

I'll see about landing the patch when I get home.

Upstream patch confirmed to work. Landing in unstable soon.

JoshStrobl added a comment.EditedNov 17 2016, 2:08 PM

Investigating it not finding our libdns_sd in avahi.

So, not entirely confident it is an issue with our Avahi, given we have all the appropriate .so files, so digging further.

If there was, I would've commented about it.

JoshStrobl closed this task as Resolved.Jan 4 2017, 2:34 AM

Landed in unstable as of https://git.solus-project.com/packages/google-play-music-desktop-player/commit/?id=63825b407cd524c6ecad1550cbbbf33b4c0ee00a

Sorry for the delay folks. @saintdev had it working locally and I couldn't reproduce. Changed our nodejs back to 6.x LTS series (for different reasons, mind you) and updated the gpmdp to 4.0.5 and it works.