Page MenuHomeSolus

Issue with language selection in installer
Migrated to GithubPublic

Description

When the installer is launched when running live, language is asked. When selecting English (UK), keyboard layout is set to English (UK) too. When switching keyboard layout to English (International AltGr dead keys), it remains in UK layout. It is fixed by first selecting English (US), then selecting English (International AltGr dead keys). This only persists during installation, when booting for the first time, the keyboard layout is correctly set to the keyboard layout selected during installation. This, however, resulted in my password being set using English (GB), and when trying to enter my password on first boot, it was in English (US).

Steps to reproduce:

  • Boot live image
  • Start installer
  • Select English (GB) as system language
  • Select English (International AltGr Dead Keys) as keyboard layout
  • Enter something in the "test this layout box" (E.g. #, or Shift+3). This results in a British pound sign being shown
  • Select English (US) in keyboard layout selection
  • Test your layout again, see that shift+3 has changed from pound sign to #
  • Switch back to English (International AltGr dead keys)
  • Test layout again, see that shift+3 has remained as #

Horribly confusing on first boot. Since this affects both Disk Encryption password and user password.

Event Timeline

kyentei created this task.Oct 6 2017, 6:34 PM

The step in the Solus installer where the keyboard layout is switched from English US to English UK is when you arrive at "Choose keyboard layout" after finishing "Find location".

DataDrake triaged this task as Normal priority.Oct 16 2018, 4:56 PM
DataDrake closed this task as Migrated.Feb 19 2022, 2:36 PM
DataDrake claimed this task.
DataDrake added a subscriber: DataDrake.

Moved to GitHub for the new installer https://github.com/getsolus/solus-installer/issues/13