Page MenuHomeSolus

Gnome MPV tearing
Closed, ResolvedPublic

Description

Watch full HD mkv movies shows tearing on intel integrated GPU on my Dell XPS notebook.

inxi -G
Graphics:  Card: Intel Device 5916
           Display Server: x11 (X.Org 1.18.4 ) drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1920x1080@59.93hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) version: 4.5 Mesa 17.1.8

It worked fine before (as in a week or two ago). Nothing changed on my end, apart from I keep switching the DE between Budgie en Gnome Shell, so I expect an update somewhere in the stack broke it.

sankasan created this task.Oct 4 2017, 8:19 PM

Please explain how to add a project when entering a bug.

JoshStrobl edited projects, added Software; removed Lacks Project.Oct 5 2017, 1:50 PM
sankasan updated the task description. (Show Details)Oct 5 2017, 6:01 PM

I have also experienced this. I have talked to the GNOME MPV developers and they are aware of screen tearing on certain systems. @TingPing

Is this persisting after the latest driver + mesa updates? Also has this been tested with xorg-driver-video-intel ? Thanks!

TingPing added a comment.EditedOct 7 2017, 6:12 PM

I believe there is an issue on mpv's tracker where the developer blamed gtk as mpv directly (with opengl output) shouldn't tear.

EDIT: https://github.com/gnome-mpv/gnome-mpv/issues/232

With the latest mesa + intel driver updates the tearing is still there. I saw the folowing quote which might be a workaround (you lose the UI overlay though):

open gnome-mpv - press CTRL+P - Unmark "Enable client-side decoration"(its a first option.my english is not good^_^)its work on me

I'll be testing this a bit more. If it doesn't work I'll update.

CSD is known to cause performance issues with GNOME MPV, @flexiondotorg had to do the same under Ubuntu MATE iirc.

aszrul added a subscriber: aszrul.Nov 28 2017, 12:11 AM

@sankasan, I can confirm that by unmarking "Enable client-side decoration" did solved that MPV tearing (With the latest Mesa + Intel Driver updates).

bwat47 added a subscriber: bwat47.Dec 4 2017, 3:25 AM

I can also confirm that disabling CSD solves the tearing with latest Mesa and xorg-driver-video-intel.

Is this issue still there for those who have an intel integrated GPU ?

No tearing for me at all with 1080p x264/x265 videos.

DataDrake triaged this task as Normal priority.Jul 29 2018, 1:40 PM
DataDrake closed this task as Resolved.Oct 20 2018, 4:09 PM
DataDrake claimed this task.
DataDrake added a subscriber: DataDrake.

Closing due to lack of activity in over 30 days. Marking resolved per last comment.