Page MenuHomeSolus

[Update] Visual Studio Code
Closed, ResolvedPublic

Description

Extensions do not appear:

Event Timeline

devlcp created this task.Sep 4 2016, 8:06 AM

Some more details would be appreciated. Is this the OSS version in the repo or vscode-ms from 3rd-Party?

Some more details would be appreciated. Is this the OSS version in the repo or vscode-ms from 3rd-Party?

No, is normal repo:

List to 3rd-Party:

cybre added a subscriber: cybre.Sep 4 2016, 12:35 PM

The open-source version does not support extensions.
Install the proprietary version if you wish to use the extensions.

JoshStrobl closed this task as Invalid.Sep 4 2016, 3:16 PM

This indicates it is possible. Could probably make the proprietary version redundant as a third party application.

Timalex reopened this task as Open.Sep 27 2016, 3:18 PM
JoshStrobl closed this task as Resolved.EditedSep 27 2016, 5:54 PM
JoshStrobl claimed this task.

Did I ask for you to reopen this issue?

I will investigate this. But don't reopen issues.

JoshStrobl changed the edit policy from "All Users" to "Restricted Project (Project)".Sep 27 2016, 5:55 PM

It seemed obvious to open it for investigation, was just trying to help. Not my intention to offend anyone by reopening the issue.

P.S. Seeing the edit policy changed makes me wonder if T156 is possible now as well.

No problem. Regardless, it's been resolved in our Visual Studio Code. I've been now using the open source version instead of the Microsoft version, and we've dropped the MS version from 3rd-Party.

Unfortunately, at least the Remote SSH extension still doesn't seem to be working (or it might be a regression, I guess). Any chance of reactivating the MS version in 3rd-Party?

JoshStrobl added a comment.EditedMar 31 2020, 6:32 PM

Any chance of reactivating the MS version in 3rd-Party?

No. If you have a regression, I'd suggest filing it with Microsoft.

I'm not the author of the Remote SSH extension. FWIW, this was brought up as a VSCode Issue first, before coming here. It seems Microsoft are not interesting in supporting builds other than their own. Any chance of a short phrase in Software Center warning people that the Solus build is likely to not work with an unknown number of extensions?