Page MenuHomeSolus

VirtualBox not working
Closed, InvalidPublic

Description

Hello dear Solus Developers!

My problem:

VirtualBox: Error -610 in supR3HardenedMainInitRuntime!
VirtualBox: dlopen(“/opt/VirtualBox/VBoxRT.so”,) failed: <NULL>

Solus: v3
kernel-header installed
system-devel installed.
Virtualbox v5.1.20 – 5.1.28 not working

I tried all versions

thank you!

Event Timeline

lacesz created this task.Sep 26 2017, 8:57 PM
Herald removed ikey as the assignee of this task. · View Herald TranscriptSep 26 2017, 8:57 PM
Herald added a subscriber: ikey.
lacesz updated the task description. (Show Details)Sep 26 2017, 8:57 PM

I've got the same problem.

sudo chown root:root /opt fixes it.

Not sure why this happened though. This is a clean install of Solus, so it can't possibly be my fault.

I think /opt does not exist on clean solus install. So either there is a problem with the virtualbox install script or with another application that you installed prior to vbox and that created the directory with wrong permissions/ownership

miwilc added a subscriber: miwilc.EditedOct 4 2017, 10:23 AM

installing google-chrome before installing vbox doesn't cause this problem.

Justin added a subscriber: Justin.Oct 15 2017, 11:16 AM

I just removed my /opt dir and installed virtualbox and ran it fine.

Are you sure you followed all the steps on the Help Center as I've just installed this on a fresh virtual machine with no issues.

Virtualbox is now in the repository. Could you try it and let us know if the problem is solved ? (make sure to install the version for the kernel you use)

The problem not solved yet, here is the screenshot

@nsiregar you should reboot after installing virtualbox or if you really don't want to reboot you have to execute sudo systemctl start vboxdrv.service before running VirtualBox

@kyrios123 i did restart, also after running sudo systemctl start vboxdrv.service not solve the problem

weird... what's the output of this command : /usr/lib64/virtualbox/vboxdrv.sh status

Here is the output

could you check the ownership of /usr/lib64/virtualbox ?
it should be root:root. If not, please let me know and run sudo chown -R root:root /usr/lib64/virtualbox

it is also root:root

I fear I'll have to dig this further because I am running out of ideas and I can't reproduce the problem.
You can update your system to see if yesterday's sync helped and repair broken packages (run this once, it will take some time and may not show much output)

sudo eopkg up
sudo eopkg check | grep Broken | awk '{print $4}' | xargs sudo eopkg it --reinstall
sudo reboot

looks like yesterday's sync doesn't helped, the VirtualBox still have same log after restart
here is the second command result in my machine

DataDrake closed this task as Invalid.Jul 12 2018, 2:05 PM
DataDrake added a subscriber: DataDrake.

If this is still an issue, please re-open, otherwise it has been over 6 months since last comment and no one else has complained.