Page MenuHomeSolus

[glibc 2.26] breaking ldd libpath lookup
Closed, ResolvedPublic

Description

I am aware we're not having 2.26 yet, but I'm opening this as a reminder since it's already happening in Arch and on Tumbleweed. We probably don't want to upgrade glibc until there is more light or a possible solution to this topic.

Following commit seems to break lookup of the library path in ldd, rendering a lot of games in Steam unplayable. The default lookup seems to be changed from x86_64 to haswell (in example).
https://sourceware.org/git/?p=glibc.git;a=commit;h=1432d38ea04ab5e96f21a382101856db5b49ad8a

Issue @ feral about this:
https://github.com/FeralInteractive/ferallinuxscripts/issues/3

Related Objects

Event Timeline

Unknown Object (User) created this task.Sep 11 2017, 5:48 PM

So - isn't this the final version of the Clear Linux patch that we already carry for 2.25? i.e. the AVX2 functionality we have.

Unknown Object (User) added a comment.Sep 11 2017, 6:23 PM

The issue is that some games seem to rely on hwcaps path x86_64 for their multilib (sub) path, and this patch renders it from x86_64 to haswell / xeon_phi.
Since hwcaps is available and certainly reports something different in an update from 2.25 to 2.26, for me personally that's breaking ABI and shouldn't have been done in the first place.

sunnyflunk added a subscriber: sunnyflunk.EditedSep 13 2017, 4:41 AM

That appears to be fixed with the patch https://sourceware.org/git/?p=glibc.git;a=commit;h=45ff34638f034877b6a490c217d6a0632ce263f4

While we are here: other notes about glibc 2.26

  • nvcc (CUDA 8) doesn't work
  • xlocale.h is gone (libicu/mesa/mlt and maybe others likely affected)
  • I believe there were a few cool performance patches that didn't make 2.26

Fox xlocale.h there is also wxwidgets and vlc I think. I already patched libicu for this in D970.

JoshStrobl edited projects, added Software; removed Lacks Project.Oct 1 2017, 12:29 PM
FireballDWF added a comment.EditedDec 9 2017, 4:39 PM

Fedora 27 and Ubuntu 17.10 have shipped with glibc 2.26

We're probably going to go with a git glibc. As for CUDA, I wouldn't really worry about that, it needs GCC 6 too.

sunnyflunk closed this task as Resolved.Mar 19 2018, 1:53 AM
sunnyflunk claimed this task.