Page MenuHomeSolus

Bug: TP-Link AC1300 / Archer T6E (wl) wireless driver malfunctioning
Closed, ResolvedPublic

Description

Hello. I just installed a TP-Link AC1300 (model no. is Archer T6E) into my computer. It's a PCI-E wireless internet card, and while the installation went OK*, I now find that sometimes when I connect to a different wireless access point, it freezes my entire computer, leaving me no recourse but to restart it. Oh, and as a side-note, sometimes the network icon just disappears from my system tray. I assume this is a related issue, as it started happening when I installed the internet card.

I'm not certain if there are logs or anything I can provide that shows what the issue is - if there are, let me know where to find them and I'll post them.

*P.S. While the installation did go off OK, it seems that you have to have Internet connectivity to install additional drivers from the hardware drivers dialog. It might be a good idea to specifically package network connectivity drivers in Solus so that if you install hardware that requires it, you don't have to connect to the Internet first to download them. For me, it was easy to resolve, as I had a working alternative means of Internet connectivity, but it'd be a hassle for people who might think the adapter would be usable right out of the box.

Event Timeline

SolarLune created this task.Sep 7 2017, 9:56 PM
SolarLune updated the task description. (Show Details)Sep 8 2017, 5:33 AM
SolarLune added a comment.EditedOct 2 2017, 6:33 PM

Small update - I installed Solus fresh using the latest ISO on a brand new hard drive, and am still having this issue.

SolarLune added a comment.EditedOct 10 2017, 3:52 PM

Another update. After reinstalling Solus, I didn't have the issue until I defined a static IP for accessing a wireless point. That froze Solus, to the point where even booting was impossible, as it kept establishing a static IP connection to the access point. Eventually I was able to get it to boot when it (for whatever reason) connected to another access point.

EDIT: Solus crashed again on a dynamic IP access point (an extender in the house), so maybe the IP address isn't the problem.

In the meantime, I tried tethering my internet through my phone (running Lineage OS, open-source hurrah). I'm getting way more speed (from 20 mbps with the card on a good day to 30 - 50, even 80 - 120 on one test). With the phone, I have way more of a stable connection, from the same location, even though it's going through USB2 and through a hub.

The PCI card cost about $50. The phone cost $69.

So... This was a nice little waste of money, I guess, haha...

JoshStrobl moved this task from Backlog to Networking on the Hardware board.Oct 26 2017, 2:02 AM
DataDrake triaged this task as Normal priority.Nov 16 2017, 11:14 PM
SolarLune added a comment.EditedNov 26 2017, 3:13 AM

Hey, tried reinstalling Solus again - still having the same issue, but very rarely (so far, anyway). If you need any logs or anything, let me know.

Not sure if any of the previous Broadcom driver updates were supposed to fix this, but I'm still having this issue as of 1/1/18.

Still an issue with the latest kernel?

SolarLune added a comment.EditedJul 31 2018, 7:41 AM

Hello! I'm late to replying, but I don't use that PCI-E card (and driver) anymore - I also changed the router out since then and reinstalled Solus fresh on my computer. However, I'm still having odd issues where the operating system crashes sometimes when connecting to an access point. It's a different card now, though, so I suppose I can make a new issue for it.

EDIT: I'll just post on the forums, I guess, and see if I can get a resolution there - might not be a bug in Solus itself. I'll close this. Thanks, though!

SolarLune closed this task as Resolved.Jul 31 2018, 3:07 PM