Page MenuHomeSolus

cdemu-daemon fails start because /dev/vhba_ctl is missing
Closed, ResolvedPublic

Description

Launching the cdemu-daemon fails because it can't find the device.

$ cdemu-daemon 
Starting CDEmu daemon with following parameters:
 - num devices: 1
 - ctl device: /dev/vhba_ctl
 - audio driver: null
 - bus type: session

cdemu0: Kernel I/O: failed to open control device /dev/vhba_ctl: No such file or directory!
cdemu: Daemon: failed to start device #0!
cdemu: Daemon: failed to create device!
Daemon initialization and start failed!

I have the relevant kernel module package installed.

$ sudo eopkg it vhba-module
The following package(s) are already installed and are not going to be installed again:
vhba-module
No packages to install.

However I don't see it in the list of available kernel modules.

$ lsmod
Module                  Size  Used by
mcs7830                16384  0
ccm                    20480  6
rfcomm                 36864  2
fuse                   81920  3
arc4                   16384  2
snd_hda_codec_hdmi     45056  1
joydev                 20480  0
hid_multitouch         20480  0
cmac                   16384  1
snd_hda_codec_realtek    69632  1
snd_hda_codec_generic    61440  1 snd_hda_codec_realtek
snd_soc_skl            49152  0
snd_soc_skl_ipc        36864  1 snd_soc_skl
snd_soc_sst_ipc        16384  1 snd_soc_skl_ipc
snd_soc_sst_dsp        16384  1 snd_soc_skl_ipc
snd_hda_ext_core       20480  1 snd_soc_skl
snd_soc_sst_match      16384  1 snd_soc_skl
snd_soc_core          159744  1 snd_soc_skl
iTCO_wdt               16384  0
snd_compress           20480  1 snd_soc_core
iTCO_vendor_support    16384  1 iTCO_wdt
ac97_bus               16384  1 snd_soc_core
bnep                   20480  2
dell_wmi               16384  0
dell_laptop            20480  0
dell_smbios            16384  2 dell_wmi,dell_laptop
dcdbas                 16384  1 dell_smbios
asix                   36864  0
usbnet                 32768  2 mcs7830,asix
mii                    16384  3 usbnet,mcs7830,asix
libphy                 36864  1 asix
intel_rapl             20480  0
snd_hda_intel          32768  5
x86_pkg_temp_thermal    16384  0
uvcvideo               81920  0
intel_powerclamp       16384  0
snd_hda_codec          94208  4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
videobuf2_vmalloc      16384  1 uvcvideo
coretemp               16384  0
videobuf2_memops       16384  1 videobuf2_vmalloc
videobuf2_v4l2         20480  1 uvcvideo
kvm_intel             180224  0
kvm                   442368  1 kvm_intel
snd_hda_core           61440  7 snd_hda_intel,snd_hda_codec,snd_hda_ext_core,snd_soc_skl,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
irqbypass              16384  1 kvm
videobuf2_core         32768  2 uvcvideo,videobuf2_v4l2
snd_hwdep              16384  1 snd_hda_codec
snd_pcm                81920  8 snd_hda_intel,snd_hda_codec,snd_hda_ext_core,snd_hda_core,snd_soc_skl,snd_hda_codec_hdmi,snd_soc_core
psmouse               114688  0
efivars                20480  0
snd_timer              28672  1 snd_pcm
evdev                  24576  17
videodev              139264  3 uvcvideo,videobuf2_core,videobuf2_v4l2
ath10k_pci             40960  0
snd                    61440  19 snd_compress,snd_hda_intel,snd_hwdep,snd_hda_codec,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek,snd_soc_core,snd_pcm
soundcore              16384  1 snd
i2c_i801               20480  0
ath10k_core           229376  1 ath10k_pci
media                  24576  2 uvcvideo,videodev
ath                    28672  1 ath10k_core
mac80211              544768  1 ath10k_core
rtsx_pci_ms            16384  0
i915                 1118208  34
memstick               16384  1 rtsx_pci_ms
btusb                  40960  0
btrtl                  16384  1 btusb
btbcm                  16384  1 btusb
btintel                16384  1 btusb
cfg80211              450560  3 mac80211,ath,ath10k_core
bluetooth             311296  31 btrtl,btintel,bnep,btbcm,rfcomm,btusb
i2c_algo_bit           16384  1 i915
drm_kms_helper        114688  1 i915
rfkill                 20480  6 bluetooth,dell_laptop,cfg80211
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
mei_me                 24576  0
fb_sys_fops            16384  1 drm_kms_helper
i2c_designware_platform    16384  0
drm                   286720  9 i915,drm_kms_helper
i2c_designware_core    20480  1 i2c_designware_platform
mei                    61440  1 mei_me
shpchp                 32768  0
thermal                20480  0
wmi                    16384  1 dell_wmi
msr                    16384  0
battery                20480  0
intel_vbtn             16384  0
video                  36864  3 dell_wmi,dell_laptop,i915
pinctrl_sunrisepoint    28672  0
pinctrl_intel          20480  1 pinctrl_sunrisepoint
button                 16384  1 i915
intel_hid              16384  0
sparse_keymap          16384  3 dell_wmi,intel_hid,intel_vbtn
ac                     16384  0
acpi_pad               16384  0
tpm_tis                16384  0
tpm_tis_core           20480  1 tpm_tis
tpm                    40960  2 tpm_tis,tpm_tis_core
binfmt_misc            16384  1
hid_generic            16384  0
usbhid                 45056  0
rtsx_pci_sdmmc         20480  0
mmc_core              110592  1 rtsx_pci_sdmmc
serio_raw              16384  0
nvme                   28672  1
nvme_core              53248  3 nvme
rtsx_pci               40960  2 rtsx_pci_sdmmc,rtsx_pci_ms
xhci_pci               16384  0
xhci_hcd              143360  1 xhci_pci
usbcore               176128  8 usbnet,uvcvideo,usbhid,xhci_pci,mcs7830,btusb,asix,xhci_hcd
usb_common             16384  1 usbcore
i2c_hid                20480  0
hid                   106496  4 i2c_hid,hid_generic,usbhid,hid_multitouch

Are there manual steps I need to do to get this working?

Event Timeline

sankasan created this task.Aug 21 2017, 3:47 PM

Relevant package is cdemu-client.Unsure how to link this so here is the full link https://dev.solus-project.com/source/cdemu-client/repository/master/

The issue is vhba-module it needs to be ported to create modules for the -lts and -current kernels, and then be added to kernel rebuild list

ikey changed the task status from Open to In Progress.Sep 22 2017, 4:09 AM
ikey claimed this task.

Sorry about ! Ok so after the sync you can install vhba-module-current if you're on linux-current. By way of apology I've also updated all the cdemu things :)

ex47 reopened this task as Open.Jun 29 2018, 1:43 AM
ex47 added a subscriber: ex47.

I think it's happening again?

@ex47, you need to have the vhba-module package installed. It isn't part of a base install.

ex47 added a comment.Jun 29 2018, 1:53 AM

@DataDrake

ex47@k ~ $ sudo eopkg it vhba-module
The following package(s) are already installed and are not going to be installed again:
vhba-module
No packages to install.

Like it was previously mentioned, you need the package for your kernel. If you have just installed from an ISO, your kernel will be linux-current so you will need to install vhba-module-current. If you have switched to the linux-lts kernel, you will need to install vhba-module-lts.

ex47 added a comment.EditedJun 29 2018, 1:58 AM

@DataDrake

ex47@k ~ $ modprobe vbha
modprobe: FATAL: Module vbha not found in directory /lib/modules/4.16.15-76.current
ex47@k ~ $ sudo eopkg it vhba-module-current 
The following package(s) are already installed and are not going to be installed again:
vhba-module-current
No packages to install.

I'm new to linux but I think it's installed.

Looks like three's a mismatch between the version of the running kernel and the module that you installed. They always need to match one another. You will need to make sure both linux-current and vhba-module-current have been updated and that your system has rebooted before loading the module.

In T4353#119005, @ex47 wrote:

ex47@k ~ $ modprobe vbha

Also this won't work cause it's spelt wrong.. modprobe vhba

ex47 added a comment.Jun 29 2018, 2:07 AM


And I've rebooted several times. Is there another way to check for updates?

ex47 closed this task as Resolved.Jun 29 2018, 2:10 AM

@sunnyflunk lol thanks. It works now.