Page MenuHomeSolus

Budgie High CPU usage with AMD Ryzen processor and NVidia graphics on Solus.
Closed, ResolvedPublic

Description

Hello all,

I am having a consistent high CPU usage by the Budgie desktop environment running on Solus, often reaching 350%+ CPU on a single process, in addition to up to 20% on other 16, according to htop. Rarely, it would hit 600% and 55% CPU usage on those same processes.

The tested kernels were 4.9.22-17.lts and 4.12 (linux-current today), while the 4.9 was also tested on a fresh OS installation.

The ~/.xsession-errors file was empty.
I am attatching my sudo journalctl -a output:


dmesg:

and lastly, my pstree:

This is my system:
http://pasted.co/ddb4db1d

Here is a screenshot of htop:
http://imgur.com/a/2g2jo

It looks like having a browser open, be it Firefox or Google Chrome, has a big impact on this cpu usage, as it instantly goes from 200% CPU to 350% as soon as I open them. The same can be observed with multimedia software such as playing a video on MPV.
Having Gnome MPV idle (as in no video file open) seems to have no impact on the cpu usage of the environment.

The lowest CPU usage (95~100%) happens with no multimedia capable applications running, no streaming or media players of any kind.

Event Timeline

dejaime created this task.Aug 19 2017, 6:24 AM
dejaime updated the task description. (Show Details)Aug 19 2017, 6:26 AM
DataDrake edited projects, added Software; removed Lacks Project.Nov 2 2017, 3:57 PM
DataDrake added a subscriber: DataDrake.

Can't reproduce on my Ryzen system with AMD graphics. Leaning towards Nvidia driver bug?

JoshStrobl closed this task as Resolved.Jan 27 2018, 2:48 PM
JoshStrobl claimed this task.
JoshStrobl added a subscriber: JoshStrobl.

Not able to reproduce either. Closing due to:

  1. Lack of response.
  2. The kernel in use is pretty old and doesn't remotely compare to changes in latest LTS and current (4.14.x)
Beer added a subscriber: Beer.May 4 2018, 3:48 PM

This is still a problem on Solus Budgie as of today using the current kernel (non-lts), and has been for well over a year. There are loads of threads about this issue scattered around and as far as I've seen, it's never been officially addressed.

This has definitely been unique to budgie in my experience, so I don't think it's necessarily just a driver bug. Or if it is, it's a driver bug related to something only budgie-wm is doing. I haven't had this issue with any other wm/de

From my research, the problem seems to be compounded by using higher resolution displays.

https://github.com/budgie-desktop/budgie-desktop/issues/1002
https://solus-project.com/forums/viewtopic.php?t=4864
https://github.com/budgie-desktop/budgie-desktop/issues/1079
https://github.com/budgie-desktop/budgie-desktop/issues/1379
https://github.com/budgie-desktop/budgie-desktop/issues/631
https://solus-project.com/forums/viewtopic.php?t=2325

Can this possibly be revisited? Thanks

For 4k displays you need to use force full pipeline composition when using NVIDIA proprietary drivers. This is specific to mutter and NVIDIA - not Budgie.
You see the same bugs reported again and again because folks refuse to look for the original reports.

Disclaimer: Using NVIDIA 396 here with a 4k panel. Without that setting - things run sluggishly.

Beer added a comment.May 4 2018, 3:59 PM

Gotcha. That is the first time I've heard any kind of official answer about this so thanks. I don't know what original reports you're referring to, but I've searched dozens of times and never saw anything more than a "it's probably just xyz", no actual confirmations beyond assumptions (until now)

These days its gonna be nigh impossible to track down originals, given stuff has been going on so long with this :P

Try the nvidia settings thing and let me know how it goes

Beer added a comment.May 4 2018, 4:44 PM

I've been doing that for a while now and it does work. But I've also heard (not sure if this is actually true) that it disables Gsync. I very irresponsibly dropped $800 on a gsync monitor so... yeah. Heh.

Either way, I really just felt like this was a bandaid fix for an issue with budgie-wm and wanted to see if someone could look into it. But if it has nothing to do with Budgie then we're golden.

I've gsync here, had nothing but pain with it and I have to toggle gsync off and on again :D FWIW I've just rebooted to 4.16.7 kernel and I wasn't getting the stuttering.
So let's see how you are after we sync these? :D

Beer added a comment.May 4 2018, 6:21 PM

Good to hear, thanks man! I'll give it a shot when it's out.