Page MenuHomeSolus

Software Center allows "install" of installed applications
Closed, ResolvedPublic

Description

Software Center -> installed -> Rhythmbox allows "install"
(it is installed out of the box)
nothing happens on click on "install" apart from "uninstall" becoming available

might affect more pre-installed apps, e.g. calendar

Event Timeline

julius16 created this task.Aug 15 2017, 7:34 AM
richardk added a subscriber: richardk.EditedAug 18 2017, 3:29 AM

I think I can provide more information on this bug. I think it is a bug in the Software Center itself:

tested in virtualbox
confirmed in all 3 versions: budgie, mate, gnome

Steps to reproduce:

  1. From fresh install, remove a default application (ex: HexChat).
  2. Without closing the Software Center: go back and look up another application/package (I think ANY package. If not, then almost all others). Instead of "remove", you will see an "install," even though the package is already installed.
  3. If you click on the "install," you need to authenticate, and then ALL other packages show "remove" again. i.e. they return to the expected state.
  4. If you close the Software Center and reopen, the buttons all return back to "remove" as they should. i.e. closing the Software Center seems to resolve the problem.
  5. However, if you remove another package, the same problem recurs.
richardk added a comment.EditedAug 18 2017, 3:32 AM

I just noticed that this is a duplicate of this bug: https://dev.solus-project.com/T1258
I filed the bug here: https://github.com/solus-project/solus-sc/issues/141

DataDrake edited projects, added Software; removed Lacks Project.Aug 20 2017, 10:42 PM
JoshStrobl closed this task as Resolved.Mar 15 2018, 3:16 PM
JoshStrobl claimed this task.
JoshStrobl added a subscriber: JoshStrobl.

Closing as we're consolidating SC tasks over to its GitHub.