Page MenuHomeSolus

Should wait until keyboard/mouse are available before showing password field or text cursor
Closed, ResolvedPublic

Description

Each time I start up Solus, the password field shows up with a flashing text cursor a few seconds before I can actually type into it. If there's a way to check to see if a keyboard and/or mouse is connected, I'd like it to wait until then before the text cursor is shown in the password field.

Also, related: how would I troubleshoot a longer-than-normal wait for keyboard input?

Event Timeline

yaomtc created this task.Aug 6 2017, 2:26 PM
yaomtc added a comment.Aug 6 2017, 2:37 PM

Oops, guess I should've searched for "password delay" instead of login delay.

@yaomtc I assume this is regarding encryption? If not, I'll remove it as a duplicate and re-open, assuming there are more details regarding the keyboard device (if it's bluetooth, I think there is another issue open for that), if it's for LightDM or GDM, etc.

yaomtc added a comment.Aug 6 2017, 2:59 PM

It's just regular login, I don't have encryption enabled. Unless it's enabled by default, I haven't checked.

It's a Mistel Barocco, a USB QWERTY keyboard with a split US layout, connected via a USB extension cable.

JoshStrobl reopened this task as Open.Aug 6 2017, 3:00 PM

Gotcha. What edition is this on?

yaomtc added a comment.Aug 6 2017, 3:06 PM

Of Solus? Budgie, with its default DM.

Gotcha, so LightDM. Is this with the snapshot or a Patreon ISO? Asking because we switched over to using slick-greeter instead of lightdm-gtk-greeter, so trying to figure out where the problem is.

yaomtc added a comment.Aug 6 2017, 3:10 PM

A snapshot, I'm not a Patreon supporter atm

Okay, can you install slick-greeter and onboard, uninstall lightdm-gtk-greeter, and reboot? You should be greeted (pun intended) with slick-greeter and ideally be able to immediately type.

yaomtc added a comment.Aug 6 2017, 7:59 PM

Well, it does work, but I have the same problem as before - a 5-6 second delay before I can type. Here's the latest from the system journal, if that helps. (The time is wrong initially, until I click to connect to the Internet and it syncs.)

-- Reboot --
Aug 06 19:19:54 solusdesk systemd[827]: Starting Paths.
Aug 06 19:19:54 solusdesk systemd[827]: Reached target Paths.
Aug 06 19:19:54 solusdesk systemd[827]: Starting -.slice.
Aug 06 19:19:54 solusdesk systemd[827]: Created slice -.slice.
Aug 06 19:19:54 solusdesk systemd[827]: Starting Timers.
Aug 06 19:19:54 solusdesk systemd[827]: Reached target Timers.
Aug 06 19:19:54 solusdesk systemd[827]: Starting D-Bus User Message Bus Socket.
Aug 06 19:19:54 solusdesk systemd[827]: Listening on D-Bus User Message Bus Socket.
Aug 06 19:19:54 solusdesk systemd[827]: Starting Sockets.
Aug 06 19:19:54 solusdesk systemd[827]: Reached target Sockets.
Aug 06 19:19:54 solusdesk systemd[827]: Starting Basic System.
Aug 06 19:19:54 solusdesk systemd[827]: Reached target Basic System.
Aug 06 19:19:54 solusdesk systemd[827]: Starting Default.
Aug 06 19:19:54 solusdesk systemd[827]: Reached target Default.
Aug 06 19:19:54 solusdesk systemd[827]: Startup finished in 30ms.
Aug 06 19:19:54 solusdesk systemd[827]: Starting D-Bus User Message Bus...
Aug 06 19:19:54 solusdesk systemd[827]: Started D-Bus User Message Bus.
Aug 06 19:19:54 solusdesk dbus-daemon[842]: Activating systemd to hand-off: service name='org.gtk.vfs.Daemon' unit='gvfs-daemon.service'
Aug 06 19:19:54 solusdesk systemd[827]: Starting Virtual filesystem service...
Aug 06 19:19:54 solusdesk dbus-daemon[842]: Successfully activated service 'org.freedesktop.systemd1'
Aug 06 19:19:54 solusdesk dbus-daemon[842]: Successfully activated service 'org.gtk.vfs.Daemon'
Aug 06 19:19:54 solusdesk systemd[827]: Started Virtual filesystem service.
Aug 06 19:19:54 solusdesk systemd[827]: Started Virtual filesystem service.
Aug 06 19:19:54 solusdesk org.gtk.vfs.Daemon[860]: fusermount: failed to access mountpoint /run/user/1000/gvfs: Permission denied
Aug 06 19:19:54 solusdesk org.a11y.Bus[860]: Activating service name='org.a11y.atspi.Registry'
Aug 06 19:19:54 solusdesk org.a11y.Bus[860]: Successfully activated service 'org.a11y.atspi.Registry'
Aug 06 19:19:54 solusdesk org.a11y.atspi.Registry[879]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
Aug 06 19:19:54 solusdesk gnome-screensav[898]: Couldn't get presence status: The name org.gnome.SessionManager was not provided by any .service files
Aug 06 19:19:54 solusdesk gnome-keyring-pkcs11.desktop[904]: GNOME_KEYRING_CONTROL=/home/chris/.cache/keyring-X2YL4Y
Aug 06 19:19:54 solusdesk gnome-keyring-secrets.desktop[906]: GNOME_KEYRING_CONTROL=/home/chris/.cache/keyring-X2YL4Y
Aug 06 19:19:54 solusdesk gnome-keyring-ssh.desktop[907]: GNOME_KEYRING_CONTROL=/home/chris/.cache/keyring-X2YL4Y
Aug 06 19:19:54 solusdesk gnome-keyring-ssh.desktop[907]: SSH_AUTH_SOCK=/home/chris/.cache/keyring-X2YL4Y/ssh
Aug 06 19:19:54 solusdesk gsd-sharing[929]: Failed to StopUnit service: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
Aug 06 19:19:54 solusdesk gsd-sharing[929]: Failed to StopUnit service: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
Aug 06 19:19:54 solusdesk gsd-sharing[929]: Failed to StopUnit service: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
Aug 06 19:19:56 solusdesk pulseaudio[968]: [pulseaudio] source.c: Default and alternate sample rates are the same.
Aug 06 19:19:57 solusdesk pulseaudio[1039]: [pulseaudio] pid.c: Daemon already running.
Aug 06 19:19:59 solusdesk gnome-session-binary[835]: Entering running state
Aug 06 19:19:59 solusdesk gnome-screensav[1111]: screensaver already running in this session
Aug 06 19:19:59 solusdesk redshift-gtk[1108]: gdk_window_thaw_toplevel_updates: assertion 'window->update_and_descendants_freeze_count > 0' failed
Aug 06 19:19:59 solusdesk org.gtk.vfs.AfcVolumeMonitor[860]: Volume monitor alive
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: I StatusIcon    Using backend StatusIconGTK3 (primary)
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: I App
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: I App           Syncthing-GTK started and running in notification area
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: E Daemon        g-io-error-quark: Could not connect to 127.0.0.1: Connection refused (39)
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: Traceback (most recent call last):
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: Traceback (most recent call last):
Aug 06 19:19:56 solusdesk pulseaudio[968]: [pulseaudio] source.c: Default and alternate sample rates are the same.
Aug 06 19:19:57 solusdesk pulseaudio[1039]: [pulseaudio] pid.c: Daemon already running.
Aug 06 19:19:59 solusdesk gnome-session-binary[835]: Entering running state
Aug 06 19:19:59 solusdesk gnome-screensav[1111]: screensaver already running in this session
Aug 06 19:19:59 solusdesk redshift-gtk[1108]: gdk_window_thaw_toplevel_updates: assertion 'window->update_and_descendants_freeze_count > 0' failed
Aug 06 19:19:59 solusdesk org.gtk.vfs.AfcVolumeMonitor[860]: Volume monitor alive
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: I StatusIcon    Using backend StatusIconGTK3 (primary)
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: I App
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: I App           Syncthing-GTK started and running in notification area
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: E Daemon        g-io-error-quark: Could not connect to 127.0.0.1: Connection refused (39)
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: Traceback (most recent call last):
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: File "/usr/lib/python2.7/site-packages/syncthing_gtk/daemon.py", line 413, in _rest_connected
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: con = sc.connect_to_service_finish(results)
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: Error: g-io-error-quark: Could not connect to 127.0.0.1: Connection refused (39)
Aug 06 19:19:59 solusdesk syncthing-gtk[1109]: gdk_window_thaw_toplevel_updates: assertion 'window->update_and_descendants_freeze_count > 0' failed
Aug 06 19:20:00 solusdesk goa-daemon[1182]: goa-daemon version 3.24.2 starting
Aug 06 19:20:01 solusdesk budgie-panel.desktop[1050]: 1502061601467        addons.xpi-utils        WARN        Synchronous load of XPI database due to getAddonsByType([theme, webextension-theme])
Aug 06 19:20:01 solusdesk budgie-panel.desktop[1050]: 1502061601642        addons.webextension.jid1-xUfzOsOFlzSOXg@jetpack        WARN        Loading extension 'jid1-xUfzOsOFlzSOXg@jetpack': Reading manifest
Aug 06 19:20:01 solusdesk budgie-panel.desktop[1050]: 1502061601658        addons.webextension.jid1-xUfzOsOFlzSOXg@jetpack        WARN        Please specify whether you want browser_style or not in your page
Aug 06 19:20:04 solusdesk Syncthing-GTK.desktop[1109]: I App           updatecheck: disabled
Aug 06 19:20:08 solusdesk gsd-sharing[929]: Failed to StopUnit service: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
Aug 06 19:20:08 solusdesk gsd-sharing[929]: Failed to StopUnit service: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
Aug 06 19:20:08 solusdesk gsd-sharing[929]: Failed to StopUnit service: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
Aug 06 19:20:21 solusdesk gsd-sharing[929]: Failed to StopUnit service: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
Aug 06 19:20:21 solusdesk gsd-sharing[929]: Failed to StopUnit service: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
Aug 06 19:20:21 solusdesk gsd-sharing[929]: Failed to StopUnit service: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
Aug 06 19:20:22 solusdesk pulseaudio[968]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate service 'org.bluez': timed out
Aug 06 15:20:41 solusdesk systemd[827]: Time has been changed
Aug 06 15:24:23 solusdesk budgie-panel.desktop[1050]: *** BUG ***
Aug 06 15:24:23 solusdesk budgie-panel.desktop[1050]: In pixman_region_append_non_o: The expression y1 < y2 was false
Aug 06 19:19:59 solusdesk org.gtk.vfs.AfcVolumeMonitor[860]: Volume monitor alive
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: I StatusIcon    Using backend StatusIconGTK3 (primary)
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: I App
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: I App           Syncthing-GTK started and running in notification area
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: E Daemon        g-io-error-quark: Could not connect to 127.0.0.1: Connection refused (39)
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: Traceback (most recent call last):
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: File "/usr/lib/python2.7/site-packages/syncthing_gtk/daemon.py", line 413, in _rest_connected
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: con = sc.connect_to_service_finish(results)
Aug 06 19:19:59 solusdesk Syncthing-GTK.desktop[1109]: Error: g-io-error-quark: Could not connect to 127.0.0.1: Connection refused (39)
Aug 06 19:19:59 solusdesk syncthing-gtk[1109]: gdk_window_thaw_toplevel_updates: assertion 'window->update_and_descendants_freeze_count > 0' failed
Aug 06 19:20:00 solusdesk goa-daemon[1182]: goa-daemon version 3.24.2 starting
Aug 06 19:20:01 solusdesk budgie-panel.desktop[1050]: 1502061601467        addons.xpi-utils        WARN        Synchronous load of XPI database due to getAddonsByType([theme, webextension-theme])
Aug 06 19:20:01 solusdesk budgie-panel.desktop[1050]: 1502061601642        addons.webextension.jid1-xUfzOsOFlzSOXg@jetpack        WARN        Loading extension 'jid1-xUfzOsOFlzSOXg@jetpack': Reading manifest
Aug 06 19:20:01 solusdesk budgie-panel.desktop[1050]: 1502061601658        addons.webextension.jid1-xUfzOsOFlzSOXg@jetpack        WARN        Please specify whether you want browser_style or not in your page
Aug 06 19:20:04 solusdesk Syncthing-GTK.desktop[1109]: I App           updatecheck: disabled
Aug 06 19:20:08 solusdesk gsd-sharing[929]: Failed to StopUnit service: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
Aug 06 19:20:08 solusdesk gsd-sharing[929]: Failed to StopUnit service: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
Aug 06 19:20:08 solusdesk gsd-sharing[929]: Failed to StopUnit service: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
Aug 06 19:20:21 solusdesk gsd-sharing[929]: Failed to StopUnit service: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
Aug 06 19:20:21 solusdesk gsd-sharing[929]: Failed to StopUnit service: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
Aug 06 19:20:21 solusdesk gsd-sharing[929]: Failed to StopUnit service: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
Aug 06 19:20:22 solusdesk pulseaudio[968]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate service 'org.bluez': timed out
Aug 06 15:20:41 solusdesk systemd[827]: Time has been changed
DataDrake edited projects, added Software; removed Lacks Project.Aug 20 2017, 10:59 PM

I've noticed that this doesn't happen when a filesystem check happens on boot. I guess that adds the few extra seconds that are required to have the mouse/keyboard ready for the login.

yaomtc closed this task as Resolved.Dec 11 2017, 10:55 PM
yaomtc claimed this task.

This doesn't happen anymore. Probably because I finally switched from linux-lts to linux-current.