Page MenuHomeSolus

Firejail & Thunderbird doesn't work out of the box
Closed, ResolvedPublic

Description

Firejail includes the useful firecfg utility to automatically create application shortcuts in /usr/local/bin to run application in a "sandbox." The tool reports that /usr/local/bin doesn't exist, but after making the directories it works, so that's no issue.

The Thunderbird application shortcut gets made as well, but does not work with Thunderbird. If I'm not mistaken this is because the system application shortcut for Thunderbird is "thunderbird", while Firejail creates a "thunderbird-bin" shortcut. Is it possible to perhaps also let the system shortcut point to "thunderbird-bin"? Or does the fault lie with Firejail?

Event Timeline

anaknaga created this task.Jul 13 2017, 1:17 PM

So, the problem is an inconsistency in /usr/share/applications/thunderbird.desktop

The problem is "Exec=/usr/bin/thunderbird %u". For (any?) other application this line is simply set to i.e. "Exec=firefox %u". The "/usr/bin" is redundant. Solution is to copy the thunderbird desktop file to ~/.local/share/applications and edit out the "/usr/bin" but I think it should be fixed in /usr/share/applications instead.

So I'm marking this as a bug for this reason, hope that's ok.

JoshStrobl edited projects, added Software; removed Triage Team.Jul 16 2017, 10:59 AM
JoshStrobl added a subscriber: JoshStrobl.

So I'm marking this as a bug for this reason, hope that's ok.

Sure, had you used the right project :P

JoshStrobl triaged this task as Normal priority.Jul 16 2017, 10:59 AM
JoshStrobl moved this task from Backlog to Package Fixes on the Software board.

Hah, picked it with my eyes closed :)!

kyrios123 closed this task as Resolved.Sep 27 2017, 11:30 AM
kyrios123 claimed this task.
kyrios123 added a subscriber: kyrios123.

Thunderbird shortcut has been fixed
The new version of firejail automatically creates /usr/local/bin if it doesn't exists.