Page MenuHomeSolus

Kirigami UI Framework
Closed, ResolvedPublic

Description

Name: Kirigami2
Homepage: https://techbase.kde.org/Kirigami; https://api.kde.org/kirigami/html/
License: LGPLv2
Why: Useful components for mobile and desktop UI creation with QtQuick. It is also a dependency of some newer applications using KF5 libraries.
Source Tarball: https://download.kde.org/stable/kirigami/kirigami2-2.2.0.tar.xz

Event Timeline

Ok, so it appears this actually requires a glibc release >= 44. Otherwise I have a working patch.

So do you want this for development or as a dep of something else? Usually you would request that app if the latter. And if it's discover it's kind of in a funny spot...I don't imagine it replaces the software center and what value does it add outside of that?

It will build against whatever is in unstable (and depend on those versions). There was a rebuild of glibc since the last sync to fix an issue so that needs to be installed.

Basically if you want it for dev purposes, then absolutely, but I'll have to look at discover before it's included (you can hastebin the yml's on the plasma spreadsheet so I can check it out more easily if that's where it's going)

Clifspeare added a comment.EditedJun 26 2017, 1:11 AM

Yeah, I agree that discover is currently a mess. I really just want it for development - the reference to other applications using it (currently just discover) was just me trying to put as much info as possible on the package request.

sunnyflunk triaged this task as Normal priority.Jun 26 2017, 1:49 AM

Ok go for it and I'll merge it