Page MenuHomeSolus

Solus uses too much space on EFI partition and cannot install kernel updates when there are 2 versions already installed
Closed, InvalidPublic

Description

A default Windows 10 installation creates an EFI partition of 100 MB, of which the Microsoft folder in /boot/EFI occupies 24 MB. Fedora uses 8.2 MB, the rest is taken up by com.solus-project.
As a result, kernel updates fail because there is no space left and while there is a notification that space on the EFI partition is low, the average user won't know what to do with it.

A workaround is to clear the /boot/EFI/com.solus-project directory and run sudo clr-boot-manager update, but I don't know if there are any leftovers from older kernels/initrds caused by this method.

I'm not very knowledgeable with the UEFI boot process, but does the initrd really need to live on the EFI partition? It's taking up a lot of space.
Fedora doesn't seem to do that, but then again, Fedora is using a different bootloader.

Event Timeline

You should be following our UEFI guide and creating an ESP of appropriate size: https://solus-project.com/articles/installation/disks/en/

This is linked on the download page.

Too late for that now, I guess.
Reinstalling 2 operating systems and all my applications from scratch is just too much effort for too little in return when there is a workaround.

My question still stands though, why does Solus need so much more space than any other Linux-based OS or even Windows?

Clifspeare added a subscriber: Clifspeare.EditedJun 19 2017, 11:30 PM

clr-boot-manager keeps older linux kernel versions around so the system can still boot if something gets corrupted during an update. I can't count the number of times I had to chroot in and fix stuff after an update back on Arch rendered my system unbootable.
512MB is such a negligible amount more than 100MB these days that it is considered a worthwhile tradeoff.

DataDrake closed this task as Invalid.Oct 8 2018, 11:46 AM
DataDrake added a subscriber: DataDrake.

We use more space because we keep spare kernels so that your can still boot into your system. We also leave room in case you are running both kernels (common for testers). What's heinous is that Windows only allocates 100MB because it never expects you to boot anything else.