Page MenuHomeSolus

mpv + youtub-dl error
Closed, InvalidPublic

Description

mpv + youtube-dl worked perfectly before on mpv 0.18.x but now on 0.20.0 i got this:

crash@laptop ~ $ mpv https://www.youtube.com/watch?v=EvGOCQdQZkQ
Playing: https://www.youtube.com/watch?v=EvGOCQdQZkQ
[ytdl_hook] MPEG-Dash Segments unsupported, add [protocol!=http_dash_segments] to your ytdl-format.
[ffmpeg] tls: The TLS connection was non-properly terminated.
Failed to recognize file format.

Exiting... (Errors when loading file)
crash@laptop ~ $

Event Timeline

crash created this task.Aug 28 2016, 1:24 PM
Tick added a subscriber: Tick.Aug 28 2016, 2:07 PM

The problem seems to come from mpv.
You can use this syntax until the problem is solved :

youtube-dl -o - "https://www.youtube.com/watch?v=EvGOCQdQZkQ" | mpv -

crash added a comment.Aug 28 2016, 7:03 PM

Well that is one way to go, but i don't want to download the whole file though :)

Tick added a comment.EditedAug 29 2016, 2:56 PM

I've just noticed that with others videos it works fine.
Maybe the problem comes from Youtube and the codecs used during livestreams ?

Try this one :

mpv https://www.youtube.com/watch?v=GOAEIMx39-w
crash added a comment.EditedAug 29 2016, 5:11 PM

that video worked :) and i think you are right about the problems are maybe coming from youtube.

JoshStrobl closed this task as Invalid.Sep 3 2016, 5:41 PM