Page MenuHomeSolus

soundconverter - Error installing, no gst-plugins-good dependency
Closed, ResolvedPublic

Description

Unable to install through software center. Receiving the following error from terminal install

sudo eopkg install soundconverter --debug

DEBUG: HistoryDB initialized in 0.000614881515503.
DEBUG: InstallDB initialized in 0.00286102294922.
DEBUG: ComponentDB initialized in 0.00308394432068.
DEBUG: RepoDB initialized in 9.48905944824e-05.
digraph G {


}
DEBUG: PackageDB initialized in 0.0453610420227.
DEBUG: checking gnome-python
DEBUG: checking gst-plugins-bad
DEBUG: checking gst-plugins-good
System error. Program terminated.
<type 'exceptions.Exception'>: gst-plugins-good dependency of package soundconverter is not satisfied
Please use 'eopkg help' for general help.

Traceback:
  File "/usr/bin/eopkg", line 82, in <module>
    cli.run_command()
  File "/usr/lib/python2.7/site-packages/pisi/cli/pisicli.py", line 140, in run_command
    self.command.run()
  File "/usr/lib/python2.7/site-packages/pisi/cli/install.py", line 104, in run
    pisi.api.install(packages, ctx.get_option('reinstall') or reinstall)
  File "/usr/lib/python2.7/site-packages/pisi/api.py", line 69, in wrapper
    ret = func(*__args,**__kw)
  File "/usr/lib/python2.7/site-packages/pisi/api.py", line 478, in install
    return pisi.operations.install.install_pkg_names(packages, reinstall)
  File "/usr/lib/python2.7/site-packages/pisi/operations/install.py", line 59, in install_pkg_names
    G_f, order = plan_install_pkg_names(A)
  File "/usr/lib/python2.7/site-packages/pisi/operations/install.py", line 279, in plan_install_pkg_names
    raise Exception(_('%s dependency of package %s is not satisfied') % (dep, pkg.name))

Event Timeline

DataDrake added subscribers: kyrios123, DataDrake.

I got this one @kyrios123. Looks like gst-plugins-good didn't sync for some reason. I've bumped it and it should be fixed on the next sync.

@DataDrake still on my test machine although it get installed, the application does not work.
If I run soundconverter from the command line, I get the following message:

SoundConverter 2.1.6
SoundConverter needs python-gstreamer 0.10!

This is maybe it uses R1076 while it should probably use R1077 (which has never been created).

There is another weird thing: The package is build with gstreamer-1.0 but it runs with gstreamer-0.1

@DataDrake is the problem I reported just above is a global issue and if gst-python-0.10 is required, instead of adding this dead package in the repo, I propose to exceptionally build soundconverter 3.0.0-beta1. I tested it on my side and I haven't encountered any problem with it.

It is just a suggestion of course...

@kyrios123 yeah it looks like I had a locally git gst-python-0.10 sorry, it's been way too long since I worked on this apparently. I'm working out the patches now. Cheers.

DataDrake closed this task as Resolved.Jun 17 2017, 6:30 PM

Part 2:
R2936:7da832177bcd: Fixed mistake with version of gst-python

Part 3:
R1081:50b0c8072d3e: Bump for sync

This has been fixed in unstable and will be available on the next sync. Apologies for the trouble!

Yep, thank you @DataDrake ! :)