Page MenuHomeSolus

Libre Office Spellcheck Inoperatve
Closed, ResolvedPublic

Description

I did a couple of installs with 2017.01.01 and I noticed that the Libre Office spell check was inoperative. At that time, I submitted a post to the forum on the subject.

I just used the latest ISO to do a fresh install and I noticed that this problem is still unresolved. It seems that even though Libre Office is provided with both the English dictionary and the Hunspel spellchecker by default, for some reason, Libre Office is not able to find Hunsell. My workaround was to download the English dictionary directly from the Libre Office site and then install it. Once this action is performed, Libre Office magically finds Hunspell and it now appears in the “Available writing modules” box, located at the top of the “Tools/Options/Language Settings/Writing Aids” tab.

This may not be the correct, most elegant solution, but it is effective.

Event Timeline

RenHoek created this task.Jun 15 2017, 8:33 PM

2017.01.01 is old btw. There is a new version. Install libreoffice-all or libreoffice-common-dictionaries i believe for spell check

Forgive me for not making myself clear. I will restate:

After having noticed the spellcheck problem back in January, with the older 2017.01.01 ISO / repo, I just downloaded THE MOST RECENT 2017.04.18 ISO and performed a fresh install and the problem is STILL UNRESOLVED.

Did you install libreoffice-common-dictionaries @RenHoek ?

RenHoek added a comment.EditedJun 16 2017, 1:37 AM

No sir.

libreoffice-common-dictionaries is not installed on this system. It never occurred to me that I should look in the Solus repo, when the English dictionary was already installed by default.

I downloaded the English dictionary directly from the Libre Office web site and installed it and spell check now works, even though libreoffice-common-dictionaries (what ever that is/does) is still not installed.

RenHoek added a comment.EditedJun 16 2017, 1:49 AM

I just looked at one of the systems that I installed back in January. Back then, obviously, Libre Office was not installed by default, from the ISO. When I manually installed Libre Office from the repo, that procedure did install libreoffice-common-dictionaries to my laptop. But, even though that file was present, the spell check still did not work.

It was on this system that I first noticed that even though the Hunspell file was on the disk, it wasn't registered, for lack of a better description, with Libre Office. On this system I downloaded the English Dictionary, directly from the Libre Office site and when I walked through the dictionary import/install process, LibreOffice found Hunspell and spell ckecking began to work.

Here is the original forum post.

To resolve this properly (eliminate the need for libreoffice-common-dictionaries), need to:

  1. Add support for more hunspell languages? Or just do it as people request it
  2. Add thesaurus support (mythes) for languages
  3. Possibly even some hyphen support

All 3 are provided in some form by LO dictionaries (thesaurus doesn't exist in all languages for example). Then LO can be built to use the system dictionaries and also benefit all other packages.

mramish added a subscriber: mramish.Nov 5 2017, 8:58 PM

From my perspective it would be better to use the libreoffice-common-dictionaries package. I often change languages in different documents so it would be more practical to have the "common" ones installed.

Jacalz added a subscriber: Jacalz.Apr 5 2018, 4:58 PM

I ran in to this also and thanks for how to fix it but there be some way to make it more apparent for the end user that they need "libreoffice-common-dictionaries" installed on their system. Maby add a text to "libreoffice-common" in software center that shows the need for "libreoffice-common-dictionaries" in order to get spell checking?

I think that this could be marked as resolved, looks like like "libreoffice-common-dictionaries" is installed by default in the the Solus 3.9999 ISO:s.

DataDrake closed this task as Resolved.Oct 8 2018, 11:16 AM
DataDrake claimed this task.
DataDrake added a subscriber: DataDrake.

Agreed. Thanks!