Page MenuHomeSolus

Update libwebp
Closed, ResolvedPublic

Description

Our libwebp is 0.3.1, which was released in 2013, so we should look into updating it:

https://github.com/webmproject/libwebp/archive/v0.5.1.tar.gz

This will require rebuilding quite a few deps:

  • libwebkit-gtk
  • gnome-initial-setup
  • gegl3
  • weston
  • darktable
  • libwebkit3-gtk
  • gstreamer-1.0-plugins-bad
  • imagemagick
  • midori
  • graphicsmagick
  • openimageio
  • feedreader

Related Objects

StatusAssignedTask
ResolvedJoshStrobl
WontfixDataDrake
InvalidNone

Event Timeline

Botanium added a subscriber: Botanium.
DataDrake triaged this task as Low priority.Sep 10 2016, 2:07 PM
ikey updated the task description. (Show Details)Sep 18 2016, 1:14 PM
ikey closed subtask T154: Aseprite as Wontfix.Sep 18 2016, 1:18 PM
JoshStrobl closed subtask T889: libwebp as Invalid.
JoshStrobl changed the task status from Open to In Progress.Oct 5 2016, 5:30 PM
JoshStrobl claimed this task.
JoshStrobl closed this task as Resolved.Oct 5 2016, 7:12 PM

Aside from gnome-initial-setup (which we're not using anymore and needs its patches updated), upgrade of libwebp in unstable is complete.