Page MenuHomeSolus

krusader dependencies not satisfied
Closed, ResolvedPublic

Description

Trying to use Krusader in Solus GNOME is not possible. When trying to copy a file produces an error message:

Unable to create io-slave. Cannot talk to klauncher: The name org.kde.klauncher5 was not provided by any .service files

I assume this is because I should have a proper KDE desktop configured. There is a service that is not active. But if krusader is in the repos (and please don't remove it from there!), I think all dependencies should be satisfied when installingt it.

Event Timeline

rodrum created this task.Jun 1 2017, 3:31 PM
ikey triaged this task as Low priority.Jun 1 2017, 3:39 PM
ikey added a subscriber: ikey.

Note that the KDE stuff is still very much a work in progress. It's not really meant for general use yet. Still, deps should be fixed up or down.

rodrum added a comment.Jun 1 2017, 3:54 PM

I know, I just want to help KDE in Solus become as good as the other DE options :)

Ah so you're aware of the KDE situation, my bad :D Thanks!

rodrum awarded a token.Jun 1 2017, 4:04 PM
sunnyflunk closed this task as Resolved.Jun 2 2017, 7:55 PM
sunnyflunk claimed this task.
sunnyflunk added a subscriber: sunnyflunk.

This is already resolved in unstable... Kio will now install kinit through some clever manipulation. So install kinit and the problem is gone or wait for sync and it'll be done for you