Page MenuHomeSolus

Bluetooth speakers work only in mono audio mode
Closed, ResolvedPublic

Description

Hi guys,

My Sony MDR-XB80BS bluetooth headphones get paired/detected but only work under a 'Headset Head Unit (HSP/HFP)' profile. Which means I only get a 'mono' audio mode, unlike nice stereo audio quality I used to get until (about) a month ago or so, when I could select 'AD2P' and audio quality was great.

Already asked about it on the forums:
https://solus-project.com/forums/viewtopic.php?f=9&t=7928

@sunnyflunk was really helpful and helped me cover the basics, but sadly issue is still there.

Any info about my system that I can provide to you that could help please let me know.

In case it's useful, this is my inxi -F output:

System:    Host: ***** Kernel: 4.9.30-29.lts x86_64 (64 bit) Desktop: Budgie 10.3.1
           Distro: Solus 2017.04.18.0
Machine:   Device: portable System: Dell product: Vostro 3700 v: A12
           Mobo: Dell model: 07VWR8 v: A12 BIOS: Dell v: A12 date: 04/08/2014
Battery    BAT0: charge: 52.0 Wh 471.0% condition: 11.0/52.1 Wh (21%)
CPU:       Dual core Intel Core i5 M 460 (-HT-MCP-) cache: 3072 KB 
           clock speeds: max: 2528 MHz 1: 2128 MHz 2: 1197 MHz 3: 1197 MHz 4: 1197 MHz
Graphics:  Card: NVIDIA GT216M [GeForce GT 330M]
           Display Server: X.Org 1.18.4 driver: nvidia Resolution: 1600x900@60.08hz
           GLX Renderer: GeForce GT 330M/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 340.102
Audio:     Card-1 Intel 5 Series/3400 Series High Definition Audio driver: snd_hda_intel
           Card-2 NVIDIA GT216 HDMI Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.9.30-29.lts
Network:   Card-1: Broadcom Limited BCM4313 802.11bgn Wireless Network Adapter driver: wl
           IF: wlp18s0 state: up mac: c0:cb:38:25:cf:e6
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: enp19s0 state: down mac: f0:4d:a2:a6:42:7f
Drives:    HDD Total Size: 500.1GB (16.9% used)
           ID-1: /dev/sda model: WDC_WD5000BEKT size: 500.1GB
Partition: ID-1: / size: 46G used: 25G (58%) fs: ext4 dev: /dev/sda6
           ID-2: swap-1 size: 9.74GB used: 0.00GB (0%) fs: swap dev: /dev/sda8
Sensors:   System Temperatures: cpu: 50.0C mobo: N/A gpu: 46C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 240 Uptime: 1 day Memory: 2606.7/7849.4MB Client: Shell (bash) inxi: 2.3.7

EDIT:

Wasn't aware of the lsusb command used by @swoop. In case it's useful, here's also my output:

lsusb | grep Bluetooth
Bus 001 Device 009: ID 413c:8160 Dell Computer Corp. Wireless 365 Bluetooth
Bus 001 Device 003: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)

Hope it helps.

Event Timeline

swoop added a subscriber: swoop.Jul 2 2017, 12:46 AM
This comment was removed by swoop.
swoop added a comment.Jul 2 2017, 12:51 AM

Bluetooth headphones DGTEC also only receiving mono sound on Asus tablet EP121, was previously able to select High Fidelity AD2P - (Sound Settings) - (Output Tab) - Profile: Headset Head Unit (HSP/HFP) is all that's available for selection.

lsusb |grep Bluetooth
Bus 001 Device 005: ID 0cf3:3005 Atheros Communications, Inc. AR3011 Bluetooth

m-delvalle updated the task description. (Show Details)Aug 21 2017, 11:21 PM
JoshStrobl moved this task from Backlog to Other on the Hardware board.Oct 26 2017, 2:38 AM

I can confirm my Bluetooth is working beautifully after last (yesterday's) set of updates. Yay..!

Thanks for all your work :)

P.S.: If I'm the one supposed to close this issue (given I was the author in the first place) please let me know (since I dont' see an option I assume I lack privileges or something). Cheers!

kz6fittycent closed this task as Resolved.Dec 9 2017, 1:44 AM
kz6fittycent claimed this task.
kz6fittycent added a subscriber: kz6fittycent.

As per m-delvalle, issue resolved.

Thanks for everyone's help with this one! Also, m-delvalle, thanks for reporting back.