Page MenuHomeSolus

LibreOffice does not start at all
Closed, ResolvedPublic

Description

I tried to use LibreOffice but it won't work. It only shows the splash screen for a second or less and the it disappears and nothing happens.

Running LibreOffice from the terminal gives me the following output:

~ $ libreoffice 
terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'


Fatal exception: Signal 6
Stack:
/usr/lib64/libreoffice/program/libuno_sal.so.3(+0x3cf58)[0x7f436aeaef58]
/usr/lib64/libreoffice/program/libuno_sal.so.3(+0x3d159)[0x7f436aeaf159]
/usr/lib64/libc.so.6(+0x35820)[0x7f436a842820]
/usr/lib64/libc.so.6(gsignal+0x9f)[0x7f436a8427af]
/usr/lib64/libc.so.6(abort+0x16a)[0x7f436a8443aa]
/usr/lib64/libstdc++.so.6(_ZN9__gnu_cxx27__verbose_terminate_handlerEv+0x16d)[0x7f4369ed342d]
/usr/lib64/libstdc++.so.6(+0x8f006)[0x7f4369ed1006]
/usr/lib64/libstdc++.so.6(+0x8f061)[0x7f4369ed1061]
/usr/lib64/libstdc++.so.6(+0x8f2f1)[0x7f4369ed12f1]
/usr/lib64/libreoffice/program/../program/libconfigmgrlo.so(+0x35e26)[0x7f43459b6e26]
/usr/lib64/libreoffice/program/../program/libconfigmgrlo.so(+0x362fd)[0x7f43459b72fd]
/usr/lib64/libreoffice/program/../program/libconfigmgrlo.so(+0x36cce)[0x7f43459b7cce]
/usr/lib64/libreoffice/program/../program/libconfigmgrlo.so(+0x37477)[0x7f43459b8477]
/usr/lib64/libreoffice/program/../program/libconfigmgrlo.so(+0x3b9f0)[0x7f43459bc9f0]
/usr/lib64/libreoffice/program/libutllo.so(+0x5a631)[0x7f4365072631]
/usr/lib64/libreoffice/program/libutllo.so(+0x5b28e)[0x7f436507328e]
/usr/lib64/libreoffice/program/libutllo.so(_ZN3utl10ConfigItemC2ERKN3rtl8OUStringE14ConfigItemMode+0x8a)[0x7f436506385a]
/usr/lib64/libreoffice/program/libutllo.so(+0xbf1c8)[0x7f43650d71c8]
/usr/lib64/libreoffice/program/libutllo.so(_ZN19SvtSysLocaleOptionsC1Ev+0x85)[0x7f43650d77c5]
/usr/lib64/libreoffice/program/libutllo.so(+0xeaab4)[0x7f4365102ab4]
/usr/lib64/libreoffice/program/libutllo.so(_ZN12SvtSysLocaleC1Ev+0x65)[0x7f4365102ba5]
/usr/lib64/libreoffice/program/libvcllo.so(+0x40d7b3)[0x7f4364bed7b3]
/usr/lib64/libreoffice/program/libvcllo.so(_ZN11AllSettingsC1Ev+0x47)[0x7f4364bed8e7]
/usr/lib64/libreoffice/program/libvcllo.so(+0x411498)[0x7f4364bf1498]
/usr/lib64/libreoffice/program/libvcllo.so(_ZN11Application11GetSettingsEv+0x31)[0x7f4364bf23a1]
/usr/lib64/libreoffice/program/libvclplug_gtklo.so(+0x3c9c4)[0x7f434c3d49c4]
/usr/lib64/libreoffice/program/libvcllo.so(_Z7InitVCLv+0x2ba)[0x7f4364bf74ba]
/usr/lib64/libreoffice/program/libvcllo.so(+0x4182cd)[0x7f4364bf82cd]
/usr/lib64/libreoffice/program/libvcllo.so(_Z6SVMainv+0x25)[0x7f4364bf8325]
/usr/lib64/libreoffice/program/libsofficeapp.so(soffice_main+0x9c)[0x7f436ac22fdc]
/usr/lib64/libreoffice/program/soffice.bin[0x400773]
/usr/lib64/libc.so.6(__libc_start_main+0xf1)[0x7f436a82d481]
/usr/lib64/libreoffice/program/soffice.bin[0x4007b9]

I also remove the libreoffice-common package in the Software Center and reinstalled it. But that didn't change anything.

~ $ eopkg info libreoffice-common
Installed package:
Name                : libreoffice-common, version: 5.2.0.4, release: 21
Summary             : LibreOffice Office Suite
Description         : LibreOffice Office Suite
Licenses            : BSD, GPL-2.0+, LGPL-2.0+, MPL-1.1, CDDL, Netscape, Public-Domain
Component           : office
Dependencies        : libx11 mesalib libxml2 expat harfbuzz libstdc++ libgcc libnspr libxslt curl gstreamer-1.0-plugins-base libgtk-2 dbus-glib libicu bzip2 cups libnss
                      gstreamer-1.0 fontconfig libice gdk-pixbuf libxinerama libatk libpng libxext libxrandr graphite2 pango poppler python3 liblcms2 freetype2 libcairo
                      libjpeg-turbo dbus zlib openssl libxrender glib2 libsm glibc 
Distribution        : Solus, Dist. Release: 1
Architecture        : x86_64, Installed Size: 588.71 MB
Reverse Dependencies: 

Package found in Solus repository:
Name                : libreoffice-common, version: 5.2.0.4, release: 21
Summary             : LibreOffice Office Suite
Description         : LibreOffice Office Suite
Licenses            : BSD, GPL-2.0+, LGPL-2.0+, MPL-1.1, CDDL, Netscape, Public-Domain
Component           : office
Dependencies        : libx11 mesalib libxml2 expat harfbuzz libstdc++ libgcc libnspr libxslt curl gstreamer-1.0-plugins-base libgtk-2 dbus-glib libicu bzip2 cups libnss
                      gstreamer-1.0 fontconfig libice gdk-pixbuf libxinerama libatk libpng libxext libxrandr graphite2 pango poppler python3 liblcms2 freetype2 libcairo
                      libjpeg-turbo dbus zlib openssl libxrender glib2 libsm glibc 
Distribution        : Solus, Dist. Release: 1
Architecture        : x86_64, Installed Size: 588.71 MB, Package Size: 115.22 MB
Reverse Dependencies: libreoffice-writer 

libreoffice-common package is not found in source repositories

If you need some more information about my system to solve this problem, so let me know an leave me a message.

Greetings from Germany
soulflyman

Event Timeline

Looks like java issue. Couple of things:

  1. Are you using java with libreoffice? (or using an old home directory from a previous install)
  2. If using the openjdk-8 from the repo, can you update as it's just been fixed.

Had the same issue. Installing the suite doesn't let the user do anything. One has to pick Writer, Calc, (those 42kb or so packages) etc. additionally and individually in the Software Center.

Ok confirmed that is the issue. When I uninstalled every libreoffice-{calc,writer,etc} bar -common, I got the same error.

So install libreoffice-calc (or whichever parts you want to use). Leaving it open as not sure if there's something that can be improved or it's a non issue.

@sunnyflunk I'm not sure how we would improve this, apart from having a "meta" package for libreoffice that installs the whole suite. I'm pretty sure that you can install libreoffice-base on say ubuntu or arch and have this same problem.

Thanks for your help. It works now after I installed writer and calc. Maybee we don't need a meta package. Changing the description of libreoffice-common from "LibreOffice Office Suite" to something like "LibreOffice Core. Install components separately." ore something like that could be enough information a user needs to not have this Problem.

DataDrake closed this task as Resolved.Sep 16 2016, 1:32 AM
DataDrake claimed this task.

We can look at updating the description.

I just had the same issue from installing libreoffice-common. I fixed it by installing libreoffice-base, which just installed libreoffice-writer. However I assumed install libreoffice-common would just install the full suite. Is that a separate issue?

This is why we have libreoffice-all to be honest. libreoffice-common is just the bits that are shared between the different applications in the LibreOffice suite.

That makes sense I suppose. I saw libreoffice-common, and it was the only one that had an actual icon ( other than libreoffice-writer ) , so my mind just defaulted straight to that one.