Page MenuHomeSolus

Installer fails to find ESP partition with automated installtion
Open, NormalPublic

Description

Situation: trying to install on USB drive on UEFI system using automated install.
The installation fails saying that it could not find an ESP partition on the installation drive. An ESP partition is present on the hard drive of the system, though.

Situation:
/dev/sda (hard drive of the system, not for install)
/dev/sdb (hard drive)
/dev/sdc (target USB drive for installation, ESP needs to be created)
/dev/sdd (USB drive on which solus budgie booted (April boot image))

Event Timeline

xahodo created this task.May 27 2017, 2:52 AM

Please run it from the terminal and provide output:

sudo os-installer-gtk

Also provide (after):

sudo blkid
sudo lsblk
ikey triaged this task as Normal priority.May 28 2017, 4:29 PM

Unfortunately I already installed successfully (but with the "advanced" install). I ordered an USB stick (should arrive Thursday) to figure out whether that issue happens with that one too.

Will do as requested once that USB stick has arrived. Any previous partitions on that disk have been destroyed by installing Solus, sorry. :(

I suspect that it's an issue of the target drive having a fat32 or exFAT(?) partition, which is set to not be an ESP partition. When the installer finds the partition on the device, it automatically assumes it's the ESP partition also. The USB SSD contained a FAT32 or exFAT partition (not really sure, unable to figure that out as all data of the previous partitioning (by the manufacturer) is lost).

Could this be the situation?