Page MenuHomeSolus

Dota 2 Vulkan crashes on launch 100% of the time, other Vulkan games crash when switching any graphics options
Closed, ResolvedPublic

Description

Solus is updated, GTX760, Nvidia 381.22 driver (32bit and 64bit), Vulkan 1.0.42 is installed. What I did:

  • Installed Steam (tested with stable and beta), then Dota 2 (along with Vulkan Support DLC), Serious Sam Fusion 2017 (beta) and The Talos Principle to test Vulkan performance
  • All three games play just fine with OpenGL but Serious Sam and Talos Principle crash instantly when switching the API to Vulkan ingame
  • Launching these two games with +gfx_strAPI "VLK" parameter sets Vulkan API and I can play without any errors but switching any graphics options (like AF, AA...) crashes the game
  • Dota 2 launched with -vulkan crashes, see https://hastebin.com/ovureveper.sql
  • No workshop or DLC installed other than Vulkan Support
  • Running vulkaninfo from terminal: https://hastebin.com/foyiboruyo.diff

sunnyflunk ran vulkaninfo on his Intel GPU without issues as well as Dota 2 Vulkan. I can provide more information or dump files but I don't know which ones are relevant.

Event Timeline

Havoqq created this task.May 24 2017, 10:12 AM
Havoqq updated the task description. (Show Details)May 24 2017, 10:15 AM
Havoqq updated the task description. (Show Details)

To clarify, I haven't tested dota2 vulkan recently though as I don't have the HDD space, nor the internet to download it.

Dainis added a subscriber: Dainis.May 25 2017, 5:46 PM

For Croteam games it looks like the nvidia driver is to be blamed. At least game logs tell this. Croteam also confirmed that for me on steam forums. However, on Manjaro (Cinnamon) and Ubuntu these games worked just fine on vulkan rendered.

Haven't tried DOTA2 yet, but Ballistic Overkill recently added vulkan support, and it also crashes immediately after startup. However, they are also having other issues atm, so it could be a game issue.

Timalex added a subscriber: Timalex.Jun 3 2017, 7:12 PM
Havoqq added a comment.EditedJun 5 2017, 7:19 AM

So... Today I reinstalled Solus again because I switched drives. Did all the same things again, but this time Dota 2 launched with -vulkan. I really can't say what was different this time apart from DoFlicky suggesting Nvidia blob 381 instead of 340 so I didn't have to install 381 from terminal. Any files or dumps I can provide?

Having the same problem, though with the Mad Max Vulkan Beta. It automatically crashes on startup. Nvidia 381.22 with optimus and vulkan 1.0.42.

Try not using budgie.

Or try with latest updates :)

Already have everything updated, also tried using i3 with no luck.

Perhaps this is relevant? https://dev.solus-project.com/T4291

Also, why/how did I remove suscribers? :/

Serious Sam Fusion 2017 and Talos Priciple crashes with "Fatal Error: Cannot ste display mode" pop-up, when switching from OpenGL renderer to Vulkan.
Budgie DE. Latest stable.

Having the same issue, RPCS3 (PS3 emulator) doesn't even show the option to switch to Vulkan renderer, it only has OpenGL in the list. vulkaninfo output (if it helps): https://pastebin.com/Kh43FvtQ
Nvidia driver is 384.59.

There has been a bunch of reports lately on reddit too, about vulkan not working in emulators:

https://www.reddit.com/r/SolusProject/comments/71tvcy/problems_with_vulkan_renderer_in_dolphin/

https://www.reddit.com/r/SolusProject/comments/71s88z/rpcs3_vulkan/

Is anyone there using vulkan anywhere without issues?

gavandor added a subscriber: gavandor.EditedOct 8 2017, 12:54 AM

It seems that /usr/share/vulkan/icd.d/10_nvidia.json is pointing to the wrong library, it should point to libGL.so.1
As seen here https://groups.google.com/forum/#!topic/linux.debian.bugs.dist/EGfdBpOAeAU
My file now reads:

{
    "file_format_version" : "1.0.0",
    "ICD" : {
        "library_path" : "libGL.so.1",
	"api_version": "1.0.42"
	    }
}

I've also added the api_version field because vulkaninfo complained, don't know if it's necessary.
With this Talos Principle, Serious Sam Fusion and Dota 2 are running with Vulkan.
Driver version is 384.90 on GTX970.

fourwood added a comment.EditedOct 8 2017, 1:14 AM

+1, after making that change and rebooting, the Mad Max Vulkan beta branch is running for me. (I know this is technically about Dota 2, but...)

That change also worked for me to fix Dooms Vulkan mode. Also vulkaninfo works correctly now.

gazny added a subscriber: gazny.Oct 10 2017, 4:16 AM

+1 For fixing my rpcs3 bug.

ikey claimed this task.Oct 11 2017, 7:20 PM

Yep confirmed bug local.

ikey changed the task status from Open to In Progress.Oct 11 2017, 7:45 PM

Changed our package build to manually configure the ICD files to point to Solus paths, and not GLVND paths, and now it works.

Good work finding the issue lads!

Fixed in unstable :) Gonna need to update our Vulkan ICD loader and SPIRV headers now though so we have the full feature set

JoshStrobl moved this task from Backlog to Other on the Hardware board.Oct 26 2017, 3:10 AM
hitori added a subscriber: hitori.Nov 1 2017, 2:20 PM
khalismur added a subscriber: khalismur.
yaomtc added a subscriber: yaomtc.Feb 25 2018, 11:49 PM

What's the status of this? Talos Principle seems to work in Vulkan mode for me.

Still doesn't work for me.

fbg13 added a subscriber: fbg13.May 2 2018, 6:09 PM

Works now.

fazo96 added a subscriber: fazo96.Aug 23 2018, 5:12 PM
DataDrake closed this task as Resolved.Oct 8 2018, 11:20 AM
DataDrake added a subscriber: DataDrake.

Marking as resolved for now. If someone is still experiencing the issue, please reopen and let me know which hardware you are using.

aeosynth removed a subscriber: aeosynth.Oct 9 2018, 1:06 AM
Sethox added a subscriber: Sethox.EditedOct 26 2018, 8:19 PM

DE: Budgie
CPU: Intel i7-2600K (8) @ 3.800GHz
GPU: AMD ATI Radeon R9 290
Memory: 20041MiB

vulkaninfo seems to have stopped working now, just got the "weekly update".
https://hastebin.com/xobufamuji.makefile

I was searching/looking for all the vulkan related package in the repository (via "eopkg sr", even this thread/post helped me through some packages).

But what I find curious is that every application that uses vulkan (I tested with DXVK) works normally.

Please point down the packages needed for vulkan to work (with vulkaninfo). Just want to double check so I don't reopen this unnecessarily, the fact that this issue started on Nvidia hardware makes me feel it's a problem on my end.

Edit: scratch that, as I was using battle.net (with DXVK) I thought it was ok, but looking more into it (starting a game through Battle.net) it crashed.
HeroesOfTheStorm_x64_dxgi.log:
https://hastebin.com/vexasijiji.http

To be more clear, this all worked before the update of today. As I played before the update.

Edit 2: noticed this:

$ lspci -k | grep -EA3 'VGA|3D|Display'
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290/390]
Subsystem: ASUSTeK Computer Inc. Hawaii PRO [Radeon R9 290/390]
Kernel driver in use: radeon
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii HDMI Audio [Radeon R9 290/290X / 390/390X]

Sn8z added a subscriber: Sn8z.EditedOct 30 2018, 10:09 AM

@Sethox I too got the same issue since last friday sync and I also use a R9 290.
Booting into an older kernel seems to work and correctly load the amdgpu driver again.
But exactly like you I get the output below when using the newest kernel(4.18.16-96.current) from the last update.

lspci -k | grep -EA3 'VGA|3D|Display' 
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290/390]
	Subsystem: PC Partner Limited / Sapphire Technology Hawaii PRO [Radeon R9 290/390]
        Kernel driver in use: radeon
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii HDMI Audio [Radeon R9 290/290X / 390/390X]

DE: Budgie
CPU: Intel i5 4670k @ 3.800GHz
GPU: AMD Radeon R9 290
RAM: 16000MiB @ 1333MHz

fourwood removed a subscriber: fourwood.Oct 30 2018, 4:42 PM