Page MenuHomeSolus

kivy
Open, NormalPublic

Description

Name: Kivy

Homepage: https://kivy.org/#home

Open Source: yes

Licence: under an MIT license (starting from 1.7.2) and LGPL 3 for the previous versions

Why should this be included in the repository?: allows python programmers to create android/ui applications

Link to source tarball: https://github.com/kivy/kivy/archive/1.10.0.tar.gz

github repository: https://github.com/kivy/kivy

Related Objects

Event Timeline

Read through the setup file and this is what I found in terms of dependencies so far

install_requires=['Kivy-Garden>=0.1.4', 'docutils', 'pygments'],
setup_requires=[
    'cython>=' + MIN_CYTHON_STRING
]
JoshStrobl triaged this task as Normal priority.Oct 1 2017, 12:53 PM
JoshStrobl moved this task from Backlog to Accepted For Inclusion on the Package Requests board.
joebonrichie added a subscriber: joebonrichie.

Dabbled packaging this earlier. Doesn't yet support cython 0.27 as we have in the repo (also tried building via python2 and python3 just in case).

Once this pull request is merged and a new release is tagged we can package it
https://github.com/kivy/kivy/pull/5406

Update: pull request is merged, just waiting for a new release now.

atommixz raised the priority of this task from Normal to Needs Triage.Apr 19 2018, 2:08 AM
atommixz triaged this task as Normal priority.Apr 19 2018, 2:11 AM
fourwood removed a subscriber: fourwood.Apr 19 2018, 2:40 AM
a108384 added a subscriber: a108384.Jun 7 2018, 4:19 AM

Do you think this will ever be added to Solus? Even now, It still doesn't look like Kivy officically supports cython 0.27.

When I tried to install via pip, i see this:

Detected Cython version 0.28.3

This version of Cython is untested with Kivy. While this version may
work perfectly fine, it is possible that you may experience issues. If
you do have issues, please downgrade to a supported version. It is
best to use the newest supported version, 0.25.2, but the minimum
supported version is 0.23.
    
If your platform provides a Cython package, check if you can downgrade
to a supported version. Otherwise, uninstall the platform package and
install Cython via pip:
    
  pip install -I Cython==0.25.2

Honestly, I don't even know why it says it detected Cython 0.28, unless my version was upgraded as part of the pip commands I was running when trying to get Kivy installed.

I would really like to try to do some development with Kivy.
I was trying to install it manually per the instructions on the Kivy website, but I ran into another issue saying gcc failed or something like that. I'm confused ;(

Many Thanks,
Cliff

Still waiting for a new release from upstream. Good news it that the master branch seems to support newer cython versions, see here

A new version was released, but if D3613 is merged it will no longer be compatible again. It can be overridden but no guarantees it'll work, see here

D3613 can be delayed, but it looks like it will be the same each and every time a new version of cython will be released.

hafermix lowered the priority of this task from Normal to Low.Jan 10 2019, 12:05 AM
hafermix raised the priority of this task from Low to Normal.