Page MenuHomeSolus

Mendeley crashes at first start
Closed, ResolvedPublic

Description

Once Mendeley its installed via solus-sc, it refuses to start showing a "Mendeley Crash Recovery" window that says something funny like "Oh dear, Mendeley is having a bad day...". Launching it in a terminal shows this output:

QLayout: Attempting to add QLayout "" to ToolBarActionWidget "", which already has a layout
QLayout: Attempting to add QLayout "" to ToolBarActionWidget "", which already has a layout
Qt WebEngine data directory not found at location /opt/mendeley/desktop/Qt/5.5.1/5.5/gcc_64. Trying application directory...
Installed Qt WebEngine locales directory not found at location /opt/mendeley/desktop/Qt/5.5.1/5.5/gcc_64/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /opt/mendeleydesktop/lib/mendeleydesktop/libexec/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
[0510/102323:WARNING:resource_bundle.cc(304)] locale_file_path.empty()
Qt WebEngine data directory not found at location /opt/mendeley/desktop/Qt/5.5.1/5.5/gcc_64. Trying application directory...
Qt WebEngine Plugins directory not found. Trying fallback directory... Plugins as for example video codecs MAY NOT work.
Installed Qt WebEngine locales directory not found at location /opt/mendeley/desktop/Qt/5.5.1/5.5/gcc_64/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /opt/mendeleydesktop/lib/mendeleydesktop/libexec/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
[0510/102323:WARNING:resource_bundle.cc(304)] locale_file_path.empty()
QIODevice::read (QFile, "/opt/mendeleydesktop/lib/mendeleydesktop/libexec/citeproc-js/main.html"): device not open
QIODevice::read (QFile, "/opt/mendeleydesktop/lib/mendeleydesktop/libexec/citeproc-js/src/mendeley-combined.js"): device not open
Crash handler wrote minidump /home/rodrigo/.local/share/data/Mendeley Ltd./Mendeley Desktop/minidumps/1e740246-d6ec-ec48-42113acc-15a03af2.dmp

I can confirm that the problem is not local because I had it in all the new machines where I installed Solus recently.

I have mentioned this issue in the forum (https://solus-project.com/forums/viewtopic.php?f=14&t=7513&p=22395&hilit=mendeley#p22395) and then marked it as solved because there is a workaround, that is to download the "Linux generic version" from mendeley's web site, launching the excecutable, and then closing it. After that it is possible to launch Mendeley without any issue. As I mentioned, I think that the problem is mentioned in the last lines:

QIODevice::read (QFile, "/opt/mendeleydesktop/lib/mendeleydesktop/libexec/citeproc-js/main.html"): device not open
QIODevice::read (QFile, "/opt/mendeleydesktop/lib/mendeleydesktop/libexec/citeproc-js/src/mendeley-combined.js"): device not open

This is because I compared the outputs from the terminal before and after mendeley can be launched succesfully. I hope this helps.

Event Timeline

rodrum created this task.May 10 2017, 1:34 PM
rodrum updated the task description. (Show Details)May 10 2017, 1:35 PM
ikey changed the task status from Open to In Progress.May 28 2017, 4:44 PM
ikey claimed this task.

Yeah see:

$ lseopkg mendeleydesktop-1.17.9-3-1-x86_64.eopkg|grep main\.html
/usr/share/mendeleydesktop/citeproc-js/main.html

It's packaged wrong. Fixing now

Signed up and can confirm crash

ikey closed this task as Resolved.May 28 2017, 5:04 PM

This is now fixed in https://github.com/solus-project/3rd-party/commit/c3ebe1f3347a4b442837cdb0ad489bde1e5e9d00

Please reinstall Mendeley Desktop from the SC. You will see some minor translation messages due to it using a bundled Qt but it seems
to work well enough from here. Apologies for the issue, this really should've seen better testing, but nobody had an account (until now)