Page MenuHomeSolus

VMWare player installer never completes
Closed, ResolvedPublic

Description

I know its has been rejected for VMWare player to be included as a third party app (T564), but it would be nice if the installer was able to complete.

Related Objects

Event Timeline

Some actual logs would be nice ya know.

Unknown Object (User) added a subscriber: Unknown Object (User).May 6 2017, 1:37 AM

I am able to complete with the installation. Having just one issue, which is pretty obvious.

No rc*.d style init script directories were given to the installer. You must manually add the necessary links to ensure that the vmware service at /etc/init.d/vmware is automatically started and stopped on startup and shutdown.

BTW is there anything this stuff does that open-vm-tools doesn't do ?

Some actual logs would be nice ya know.

How can i obtain the logs for you? This is the cmdline output that happens ( https://pastebin.com/0sUAuQ3n ), but this appears before the installer window appears, so its not likely the cause of the issue. I ran the installer again and now see the dialog that @STiAT mentioned, but didnt see it before as it never appeared over the installation dialog when i alt+tabbed back to it. Pressing okay in the dialog allows the installer to complete.

In T3597#63023, @ikey wrote:

BTW is there anything this stuff does that open-vm-tools doesn't do ?

I installed open-vm-tools, but didnt find any GUI app to open with it. I've used gnome boxes which is available in the repo but it runs quite slow, i tried Virtualbox and it crashes my system on any distro, so VMWare has been my only saviour for playing with VMs.

So i started up the VMWare player app from the brisk menu and had to install the necessary packages from software center (gcc, kernel-headers) to get it to begin configuring and i get to the kernel module updater dialog and click install.

Unfortunately its unable to install and gives an error message.

I capture the terminal error log.

and here is the VMWare log files.


siru added a subscriber: siru.Jun 12 2017, 9:55 AM
Chuck added a subscriber: Chuck.EditedOct 23 2017, 12:34 AM
In T3597#63021, @STiAT wrote:

I am able to complete with the installation. Having just one issue, which is pretty obvious.

No rc*.d style init script directories were given to the installer. You must manually add the necessary links to ensure that the vmware service at /etc/init.d/vmware is automatically started and stopped on startup and shutdown.

This can be rectified using:

cd /etc/init.d
sudo for i in {0,1,2,3,4,5,6}; do mkdir rc$i.d; done

Once this is done, installer should complete.

Version 14 confirmed as working in Solus.

DataDrake closed this task as Resolved.Jul 12 2018, 3:30 PM
DataDrake claimed this task.