Page MenuHomeSolus

freerdp - clipboard redirection is not working
Closed, ResolvedPublic

Description

Clipboard redirection is not working. xfreerdp command returns error message when trying to enable it:

$ xfreerdp +clipboard /v:192.168.1.1
[20:41:55:311] [2900:2901] [ERROR][com.winpr.library] - LoadLibraryA: /usr/lib64/freerdp/cliprdr-client.so: cannot open shared object file: No such file or directory

This is probably causing same clipboard problem with remmina rdp client.

Event Timeline

David82cz created this task.May 3 2017, 7:27 PM
JoshStrobl triaged this task as Normal priority.May 6 2017, 4:58 PM
JoshStrobl added a project: Software.
JoshStrobl moved this task from Backlog to Package Fixes on the Software board.
charles-m-knox added a subscriber: charles-m-knox.EditedAug 29 2017, 7:14 PM

I'm also having this issue. I would really like to know how to fix this, it's partly breaking my ability to use Solus at work. Unfortunately I'm not familiar enough with the environment to know how to fix this - do you guys have any ideas?

Also if this is not the right place to post this let me know, I'm new here.

edit: it's not completely breaking Solus for me, still able to get things done :)

$ remmina
Password: 
NX: detected keyboard type pc104/us
Remmina plugin NX (type=Protocol) registered.
Remmina plugin RDP (type=Protocol) registered.
Remmina plugin RDPF (type=File) registered.
Remmina plugin RDPS (type=Preference) registered.
Remmina plugin VNC (type=Protocol) registered.
Remmina plugin VNCI (type=Protocol) registered.
Remmina plugin XDMCP (type=Protocol) registered.
Remmina plugin GKEYRING (type=Secret) registered.
Failed to load plugin: /usr/lib64/remmina/plugins/remmina-plugin-telepathy.so.
Error: /usr/lib64/remmina/plugins/remmina-plugin-telepathy.so: undefined symbol: remmina_tp_handler_new
Remmina plugin SFTP (type=Protocol) registered.
Remmina plugin SSH (type=Protocol) registered.
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
[12:04:56:362] [2801:2824] [ERROR][com.winpr.library] - LoadLibraryA: /usr/lib64/freerdp/cliprdr-client.so: cannot open shared object file: No such file or directory
[12:04:56:482] [2801:2824] [ERROR][com.freerdp.legacy] - creating directory /root/.config/freerdp

[12:04:56:482] [2801:2824] [ERROR][com.freerdp.legacy] - creating directory /root/.config/freerdp/certs

[12:04:56:482] [2801:2824] [ERROR][com.freerdp.legacy] - creating directory /root/.config/freerdp/server

Building from source per these instructions fixed this issue (plus others) for me: https://solus-project.com/forums/viewtopic.php?t=3388

sankasan added a subscriber: sankasan.EditedOct 13 2017, 1:50 PM

They've released a new version (2.0-rc0) which might be a good time to update the package.

I've created an updated package and I'll test this on Monday at work. I'll have a look if I need to rebuild Remmina as well to make the combination work again.

I've updated the package 2.0.0-rc0 seemed to have fixed the issue indeed.

I'd recommend to update FreeRDP even though its still a pre-release version. The update frequency of these packages is very low, its been years since the last FreeRDP release, and the current version fixes quite a few real world issues. To keep Remmina working it needs to be updated as well if I understood correctly. I haven't tested that (yet).

This isn't a problem anymore since we moved to 2.0.0-rc1 in the repos. Can someone else confirm so we can close this issue?

I can confirm this works at least for me. Thank you.

I stopped using solus but when i built this version from source it worked fine.

der_eismann closed this task as Resolved.Mar 6 2018, 2:02 PM
der_eismann claimed this task.