Page MenuHomeSolus

Battery indicator missing
Closed, ResolvedPublic

Description

I have Solus MATE (uefi bootloader) with latest updates.

So I booted my ASUS Zenbook Prime UX31A notebook today to discover that battery indicator is missing now.

I thought that's a one-time glitch and rebooted again (because same had happened to Network Connection Indicator, and reboot fixed it) but to no avail,
then I thought that it maybe mate-panel issue and did mate-panel --replace only to have Network Connection Indicator missing now along with Battery Indicator.

That's quite an issue, and I wonder if updates did broken something (could it be kernel..?), anyway, this is a troublesome loss, since I care about my battery health state, and battery indicator helps to keep it in good shape (now I have to run sudo tlp-stat -b to see if my battery is low or too high on power)

UPDATE: I rebooted again with A/C power on, and had my battery indicator appeared on boot! Then I disconnected laptop from A/C and yes... it's missing again, and connecting A/C back doesn't change anything. It's officially broken.

UPDATE_1:
thanks @kyrios123 for helping me, though there is not much output since I don't really have time to bother with this, anyway, anyone who faced same problem can do what I did: add standalone applet Battery Indicator Applet which works nicely (icon looks terrible though).

UPDATE_2:
as a side effect, key combinations for decreasing/increasing keyboard/display backlight stopped working as well. I relate this to battery indicator because that, when indicator does work (when booted with A/C on) these keys work, but with indicator down, they're down too.

Event Timeline

sigireu created this task.Apr 30 2017, 6:57 AM
sigireu updated the task description. (Show Details)Apr 30 2017, 7:04 AM

I'm unable to make the icon disappear at all here on latest updated stable with MATE.

Anything in ~/.xsession-errors when this happens?

I can't reproduce the problem either... the machine was always connected to A/C though.

mate-user added a subscriber: mate-user.EditedApr 30 2017, 3:01 PM

I've also got a missing battery indicator. Screenshot here: missing battery indicator
Edit: I'm sure this happened after installing these updates:
Operation #98: upgrade
Date: 2017-04-30 02:02

*kernel-glue is upgraded from 3-190-1-x86_64 to 4-191-1-x86_64.
*ghostscript is upgraded from 9.21-11-1-x86_64 to 9.21-12-1-x86_64 with delta.
*firefox is upgraded from 53.0-92-1-x86_64 to 53.0-93-1-x86_64.
*libplist is upgraded from 1.12-5-1-x86_64 to 2.0.0-6-1-x86_64.
*nvidia-304-glx-driver-modaliases is upgraded from 304.135-135-1-x86_64 to 304.135-136-1-x86_64.
*nvidia-glx-driver-modaliases is upgraded from 375.39-139-1-x86_64 to 375.39-140-1-x86_64.
*simple-scan is upgraded from 3.24.0-4-1-x86_64 to 3.24.1-5-1-x86_64.
*nvidia-340-glx-driver-modaliases is upgraded from 340.102-99-1-x86_64 to 340.102-100-1-x86_64.
*linux-lts is upgraded from 4.9.24-22-1-x86_64 to 4.9.25-23-1-x86_64.
*mesalib is upgraded from 17.0.4-54-1-x86_64 to 17.0.5-55-1-x86_64.
*mesalib-demos is upgraded from 17.0.4-54-1-x86_64 to 17.0.5-55-1-x86_64.
*libvte is upgraded from 0.48.2-18-1-x86_64 to 0.49.1-19-1-x86_64.

Or maybe the recent upower update in a previous update which only showed this bug after restarting.

the contents of xsession-errors file

nothing suspicious though

Perhaps you could enable debug for the mate-panel to see if something appears there ?

Perhaps you could enable debug for the mate-panel to see if something appears there ?

Can you provide me with an instruction how to do it?

kyrios123 added a comment.EditedApr 30 2017, 7:27 PM

@sigireu
The easy way is to use dconf Editor and set org.mate.debug.mate-panel to true

So I have mate-panel debug to true, but xsession-errors does not show anything interesting...
What else can I do to help track it down?

kyrios123 added a comment.EditedMay 1 2017, 1:29 PM

@sigireu
I don't know. I updated my computer this morning and I don't have this problem... So I couldn't reproduce it on a VM (unstable) and on my Laptop (stable).
Perhaps you can check in /var/log if there is some other new log file (sort them by date). You could eventually have a look at the journal or and dmesg.

You could eventually run mate-panel and other mate-powermanagement stuffs from the terminal with --help to see if they accept some debug or verbose parameters.

Honestly when I face problems I just google them and I do trial & error tests but since I can't reproduce it, I fear I won't be able to help any further on this issue.

PS: do not forget to set the value back to false in dconf Editor !

I did installed Solus MATE with new distro release (04.18), the problem stands where it was.

sigireu updated the task description. (Show Details)May 3 2017, 7:06 PM
sigireu updated the task description. (Show Details)May 7 2017, 9:02 PM
neo-alquimista added a subscriber: neo-alquimista.EditedMay 17 2017, 1:44 AM

Same problem here. Here's the output of running mate-power-manager on the terminal (with --verbose):

TI:22:57:10	TH:0x11be6a0	FI:egg-debug.c	FN:egg_debug_init,306
 - Verbose debugging 1 (on console 1)GPM_VERBOSE
TI:22:57:10	TH:0x11be6a0	FI:gpm-main.c	FN:main,206
 - MATE Power Manager 1.18.0
TI:22:57:10	TH:0x11be6a0	FI:gpm-session.c	FN:gpm_session_init,511
 - idle: 0, idle_inhibited: 0, suspend_inhibited: 0
TI:22:57:10	TH:0x11be6a0	FI:gpm-session.c	FN:gpm_session_register_client,367
 - registered startup '(null)' to client id '/org/gnome/SessionManager/Client19'
TI:22:57:10	TH:0x11be6a0	FI:gpm-manager.c	FN:gpm_manager_systemd_inhibit,1743
 - Inhibiting systemd sleep
TI:22:57:10	TH:0x11be6a0	FI:gpm-manager.c	FN:gpm_manager_systemd_inhibit,1774
 - Inhibiting systemd sleep res = 0
TI:22:57:10	TH:0x11be6a0	FI:gpm-manager.c	FN:gpm_manager_systemd_inhibit,1780
 - System inhibitor fd is 13
TI:22:57:10	TH:0x11be6a0	FI:gpm-manager.c	FN:gpm_manager_systemd_inhibit,1788
 - Inhibiting systemd sleep - success
TI:22:57:10	TH:0x11be6a0	FI:egg-console-kit.c	FN:egg_console_kit_init,408
 - Failed to get session for pid 1520: The name org.freedesktop.ConsoleKit was not provided by any .service files
TI:22:57:10	TH:0x11be6a0	FI:gpm-button.c	FN:gpm_button_grab_keystring,176
 - Grabbed modmask=8000, keycode=124
TI:22:57:10	TH:0x11be6a0	FI:gpm-button.c	FN:gpm_button_grab_keystring,176
 - Grabbed modmask=8000, keycode=213
TI:22:57:10	TH:0x11be6a0	FI:gpm-button.c	FN:gpm_button_grab_keystring,176
 - Grabbed modmask=8000, keycode=150
TI:22:57:10	TH:0x11be6a0	FI:gpm-button.c	FN:gpm_button_xevent_key,203
 - could not map keysym 1008ffa8 to keycode
TI:22:57:10	TH:0x11be6a0	FI:gpm-button.c	FN:gpm_button_grab_keystring,176
 - Grabbed modmask=8000, keycode=233
TI:22:57:10	TH:0x11be6a0	FI:gpm-button.c	FN:gpm_button_grab_keystring,176
 - Grabbed modmask=8000, keycode=232
TI:22:57:10	TH:0x11be6a0	FI:gpm-button.c	FN:gpm_button_grab_keystring,176
 - Grabbed modmask=8000, keycode=160
TI:22:57:10	TH:0x11be6a0	FI:gpm-button.c	FN:gpm_button_grab_keystring,176
 - Grabbed modmask=8000, keycode=244
TI:22:57:10	TH:0x11be6a0	FI:gpm-button.c	FN:gpm_button_grab_keystring,176
 - Grabbed modmask=8000, keycode=238
TI:22:57:10	TH:0x11be6a0	FI:gpm-button.c	FN:gpm_button_grab_keystring,176
 - Grabbed modmask=8000, keycode=237
TI:22:57:10	TH:0x11be6a0	FI:gpm-button.c	FN:gpm_button_grab_keystring,176
 - Grabbed modmask=8000, keycode=236
TI:22:57:10	TH:0x11be6a0	FI:gpm-brightness.c	FN:gpm_brightness_setup_display,279
 - No outputs have backlight property
TI:22:57:10	TH:0x11be6a0	FI:gpm-brightness.c	FN:gpm_brightness_init,946
 - no XRANDR extension
TI:22:57:10	TH:0x11be6a0	FI:gpm-brightness.c	FN:gpm_brightness_update_cache,841
 - screen 1 of 1
TI:22:57:10	TH:0x11be6a0	FI:gpm-brightness.c	FN:gpm_brightness_update_cache,846
 - watching ::monitors_changed on 0x1184020
TI:22:57:10	TH:0x11be6a0	FI:gpm-brightness.c	FN:gpm_brightness_update_cache,861
 - adding resource 0x12d1b30
TI:22:57:10	TH:0x11be6a0	FI:gpm-brightness.c	FN:gpm_brightness_helper_get_value,138
 - executing /usr/sbin/mate-power-backlight-helper --get-max-brightness retval: 0
TI:22:57:10	TH:0x11be6a0	FI:gpm-idle.c	FN:gpm_idle_evaluate,186
 - session_idle=0, idle_inhibited=0, suspend_inhibited=0, x_idle=0
TI:22:57:10	TH:0x11be6a0	FI:gpm-idle.c	FN:gpm_idle_evaluate,191
 - X not idle
TI:22:57:10	TH:0x11be6a0	FI:gpm-idle.c	FN:gpm_idle_set_timeout_dim,299
 - Current idle time=432ms, timeout was 10s, becomes 10s after adjustment
TI:22:57:10	TH:0x11be6a0	FI:gpm-idle.c	FN:gpm_idle_set_timeout_dim,302
 - Setting dim idle timeout: 10s
TI:22:57:10	TH:0x11be6a0	FI:gpm-dpms.c	FN:gpm_dpms_clear_timeouts,265
 - set timeouts to zero
TI:22:57:10	TH:0x11be6a0	FI:gpm-backlight.c	FN:gpm_backlight_brightness_evaluate_and_set,304
 - 1. main brightness 1.000000
TI:22:57:10	TH:0x11be6a0	FI:gpm-backlight.c	FN:gpm_backlight_brightness_evaluate_and_set,313
 - Setting initial brightness level
TI:22:57:10	TH:0x11be6a0	FI:gpm-backlight.c	FN:gpm_backlight_brightness_evaluate_and_set,326
 - 2. battery scale 1.000000, brightness 1.000000
TI:22:57:10	TH:0x11be6a0	FI:gpm-backlight.c	FN:gpm_backlight_brightness_evaluate_and_set,345
 - 3. idle scale 1.000000, brightness 1.000000
TI:22:57:10	TH:0x11be6a0	FI:gpm-brightness.c	FN:gpm_brightness_helper_get_value,138
 - executing /usr/sbin/mate-power-backlight-helper --get-brightness retval: 0
TI:22:57:10	TH:0x11be6a0	FI:gpm-backlight.c	FN:gpm_backlight_brightness_evaluate_and_set,353
 - values are the same, no action
TI:22:57:10	TH:0x11be6a0	FI:gpm-idle.c	FN:gpm_idle_set_timeout_dim,299
 - Current idle time=467ms, timeout was 10s, becomes 10s after adjustment
TI:22:57:10	TH:0x11be6a0	FI:gpm-idle.c	FN:gpm_idle_set_timeout_dim,302
 - Setting dim idle timeout: 10s
TI:22:57:10	TH:0x11be6a0	FI:gpm-kbd-backlight.c	FN:gpm_kbd_backlight_set,144
 - Set brightness to 254
TI:22:57:10	TH:0x11be6a0	FI:gpm-idle.c	FN:gpm_idle_set_check_cpu,121
 - Setting the CPU load check to 0
TI:22:57:10	TH:0x11be6a0	FI:gpm-manager.c	FN:gpm_manager_init,1892
 - creating new control instance
TI:22:57:10	TH:0x11be6a0	FI:gpm-manager.c	FN:gpm_manager_init,1897
 - creating new tray icon
TI:22:57:10	TH:0x11be6a0	FI:gpm-engine.c	FN:gpm_engine_init,1223
 - Using per-time notification policy
TI:22:57:10	TH:0x11be6a0	FI:gpm-idle.c	FN:gpm_idle_set_timeout_blank,323
 - Setting blank idle timeout: 600s
TI:22:57:10	TH:0x11be6a0	FI:gpm-idle.c	FN:gpm_idle_evaluate,186
 - session_idle=0, idle_inhibited=0, suspend_inhibited=0, x_idle=0
TI:22:57:10	TH:0x11be6a0	FI:gpm-idle.c	FN:gpm_idle_evaluate,191
 - X not idle
TI:22:57:10	TH:0x11be6a0	FI:gpm-idle.c	FN:gpm_idle_set_timeout_sleep,340
 - Setting sleep idle timeout: 0s
TI:22:57:10	TH:0x11be6a0	FI:gpm-idle.c	FN:gpm_idle_evaluate,186
 - session_idle=0, idle_inhibited=0, suspend_inhibited=0, x_idle=0
TI:22:57:10	TH:0x11be6a0	FI:gpm-idle.c	FN:gpm_idle_evaluate,191
 - X not idle
**
ERROR:gpm-kbd-backlight.c:329:gpm_kbd_backlight_on_dbus_signal: code should not be reached
Aborted

As soon as I ran this, the battery icon appeared for a fraction of a second and then the brightness of the screen set itself to full bright. After that, it's still the same. Not working.

These were in red:

Failed to get session for pid 1520: The name org.freedesktop.ConsoleKit was not provided by any .service files

could not map keysym 1008ffa8 to keycode

I entered same command as what @neo-alquimista entered, and indicator was up for a moment and gone again after a while

Hi @ikey, any chance this will be fixed soon, maybe for the next iso snapshot ?

Yeah, upower downgrade is not possible (as the upower upgrade fixed crashes we had in GNOME land.)

I installed Solus Mate 2017.04.18.0 on a Toshiba laptop, installed all updates including upower, restarted and the battery indicator was not missing! I think this only affects installations of Solus Mate 2017.01.01.0 which have been updated to the latest version.

Justin changed the task status from Open to In Progress.Sep 21 2017, 12:12 PM
Justin claimed this task.
Justin added a subscriber: Justin.

I believe this is now patched, please upgrade all packages, log out/in, test and advise.

Thanks Justin! My battery indicator is back and works fine now.

Can't confirm as I switched to Budgie edition

Justin closed this task as Resolved.Sep 21 2017, 11:38 PM