Page MenuHomeSolus

variety 0.6.4-8-1 won't start: AppIndicator3 not available
Closed, DuplicatePublic

Description

variety 0.6.4-8-1-x86_64 doesn't start.

~$ variety 
Traceback (most recent call last):
  File "/usr/bin/variety", line 38, in <module>
    import variety
  File "/usr/lib/python2.7/site-packages/variety/__init__.py", line 111, in <module>
    from variety import VarietyWindow
  File "/usr/lib/python2.7/site-packages/variety/VarietyWindow.py", line 73, in <module>
    from variety import indicator
  File "/usr/lib/python2.7/site-packages/variety/indicator.py", line 31, in <module>
    gi.require_version('AppIndicator3', '0.1')
  File "/usr/lib/python2.7/site-packages/gi/__init__.py", line 118, in require_version
    raise ValueError('Namespace %s not available' % namespace)
ValueError: Namespace AppIndicator3 not available
ryar created this task.Apr 30 2017, 5:22 AM

Install 'libappindicator'

Have confirmed it's required and adding it as a rundep now https://git.solus-project.com/packages/variety/commit/?id=70e0c8c3c683eaa5ef395515551b2c636c861b6b