Page MenuHomeSolus

Opam
Open, NormalPublic

Description

Name : Opam
Homepage : https://opam.ocaml.org/

Why : It is OCaml's package manager, and thus easiest way to install tools like Merlin or Emacs plugins to make OCaml programming easier.

Open-source : Yes

How many users will anticipate it : Can't give any number but I would say any reasonably good OCaml programmer who happens to use Solus will anticipate it.

Source : https://github.com/ocaml/opam/archive/1.2.2.tar.gz

Details

Differential Revisions
D3990: Initial inclusion of opam

Related Objects

DataDrake renamed this task from Package request - Opam to Opam.Apr 23 2017, 3:16 PM
DataDrake triaged this task as Normal priority.
DataDrake moved this task from Backlog to Accepted For Inclusion on the Package Requests board.
Justin claimed this task.May 7 2017, 7:54 AM

I'm wondering if it's necessary to maintain this package on Solus since the ocamlbrew script builds successfully and pulls in both ocaml and opam?
See: https://opam.ocaml.org/doc/Install.html#Usingocamlbrew

@JPenuchot as above, is this still needed?

Justin closed this task as Resolved.Aug 24 2017, 4:16 AM

Closing this as no response from the original requester.

jalden reopened this task as Open.Jun 17 2018, 6:35 PM
jalden added a subscriber: jalden.

Is there a possibility of reconsidering this package for inclusion? I don't agree with the ocamlbrew arguement that was mentioned previously.

For example, the node package manager 'yarn' is available in the repo and this is very useful. I could install it from source or use a script that does not keep it up to date through eopkg but it wouldn't be nearly as convenient.

I think that have opam along with ocaml in the repo would make it much easier to get up and running with ocaml on Solus. Just like we have rust and cargo as separate packages. I think opam in the repo would be useful for the reasons stated in the original post.

Yeah, I don't know why @Justin closed this... it's still a valid request. This is me marking this as still Accepted for Inclusion.

JoshStrobl removed Justin as the assignee of this task.
JoshStrobl added a subscriber: Justin.
JoshStrobl closed this task as Wontfix.Aug 31 2018, 4:56 PM
JoshStrobl added a subscriber: JoshStrobl.

As this task has been opened for a month with nobody having stepped up to become maintainer, in addition to providing an acceptable patch for inclusion, marking as WONTFIX. Feel free to re-open when a patch has been submitted via the proper processes.

Sorry, I was meant to get round to try and package this. Last time I tried I ran into issues because the opam build scripts makes external network requests.

Although I'm not that experienced with Solus packaging, from my understanding, the chroot build environment disallows network requests during build for reproducibilities sake?

I'll have another crack at it sometime soon as OPAM v2 was recently released. I'll update this thread with any further info that I discover.

If I get it working, I'll submit a patch through the usual means, then potentially step up to maintain the package.

jalden added a comment.Oct 6 2018, 6:32 PM

I have successfully built opam through solbuild but I have to force make to build serially (by passing -j1). I have opened an issue in the opam github repo to ask if parallel builds are possible (https://github.com/ocaml/opam/issues/3585).

jalden reopened this task as Open.Oct 8 2018, 4:43 PM

I have submitted a patch for inclusion in the repo (D3990). If this patch is good, and the triage team want me to, I would be happy to step up to maintain this package.