Page MenuHomeSolus

Chrome tabs/browser constantly crashing
Closed, InvalidPublic

Description

Both chrome and chrome-dev, and I have eliminated the possibility of custom flags and hard drive failure since I just got this SSD.

GPU is an r9-280x, CPU is an i5-4670, 8gb of RAM. Tabs open when it happened: 3. Chrome://flags are at stock values. This does not happen on gentoo, with the exact same profile copied over from solus.

Attached is the core dump (of a crash that happened a few days ago) and the dmesg output (current, tab crash).
{F22346}

Update: it outright crashed now.

Event Timeline

BRM created this task.Apr 18 2017, 3:16 PM
BRM updated the task description. (Show Details)
BRM updated the task description. (Show Details)Apr 18 2017, 3:27 PM
BRM updated the task description. (Show Details)Apr 18 2017, 4:34 PM
BRM added a comment.May 16 2017, 7:43 PM

[ 1460.260436] chrome[3669]: segfault at 6e0ea86e838 ip 00005623b005271f sp 00007ffdb4f08460 error 4 in chrome[5623aa4a1000+6b74000]
[ 1594.779665] Chrome_IOThread[1194]: segfault at 20000020 ip 000055aa91ff5240 sp 00007f8c240b64f0 error 4 in chrome[55aa8f82c000+6b74000]
[ 1597.295890] chrome[4203]: segfault at 2ee5a0612e08 ip 0000555b5b70dd40 sp 00007ffc475337c8 error 4 in chrome[555b5a023000+6b74000]
[ 2031.974773] chrome[4784]: segfault at 555b61152bc0 ip 0000555b61152bc0 sp 00007ffc47531058 error 15 in chrome[555b6114c000+1e000]
[13921.284370] chrome[4332]: segfault at 1e63f8980008 ip 0000555b5ba3f027 sp 00007ffc47534180 error 4 in chrome[555b5a023000+6b74000]
[14301.499839] chrome[6581]: segfault at 1ef768500008 ip 0000555b5ba63516 sp 00007ffc47534d30 error 4 in chrome[555b5a023000+6b74000]
[14928.295009] chrome[7133]: segfault at 66e3bdede50 ip 00001401aac8ae2a sp 00007ffc47533d70 error 4
[15109.471219] chrome[5715]: segfault at 1ffffffc ip 0000555b5faf01a2 sp 00007ffc47534cc0 error 4 in chrome[555b5a023000+6b74000]
[15214.198686] chrome[7432]: segfault at 78fe8245020 ip 0000555b5b6a8d50 sp 00007ffc475331c8 error 4 in chrome[555b5a023000+6b74000]
[15250.386197] chrome[7623]: segfault at 20000000 ip 0000555b5fa3c4c3 sp 00007ffc47534d10 error 6 in chrome[555b5a023000+6b74000]
[15677.687105] mpv[8514]: segfault at 1ffffff8 ip 00007f62ae625f52 sp 00007fff4b6f70c0 error 4 in libc-2.25.so[7f62ae59c000+1c3000]
[16298.821898] chrome[7701]: segfault at 1af526900100 ip 000055804ee0a4d3 sp 00007ffc7e63b870 error 6 in chrome[55804cad3000+6b74000]
[16685.832243] chrome[10798]: segfault at 321a2a480008 ip 000055b805603b36 sp 00007fffed4f78f0 error 4 in chrome[55b803bc4000+6b74000]

Do you happen to be using the pepper flash?

BRM added a comment.EditedMay 17 2017, 12:02 PM

Do you happen to be using the pepper flash?

Yes, and another tab just segfaulted 20 minutes after I uninstalled pepper flash.

BRM added a comment.May 20 2017, 1:31 AM

Different dmesg log this time:
[13851.257981] traps: chrome[9877] trap invalid opcode ip:7faf32eea7ce sp:7ffef941bee0 error:0
[13851.257984] in libEGL.so[7faf32ee5000+8000]
[13851.597942] traps: chrome[9895] trap invalid opcode ip:7f1bfb6547ce sp:7ffe4694b6e0 error:0
[13851.597944] in libEGL.so[7f1bfb64f000+8000]
[13851.664905] traps: chrome[9897] trap invalid opcode ip:7f0d58bc67ce sp:7ffcb54d3af0 error:0
[13851.664918] in libEGL.so[7f0d58bc1000+8000]
[37708.656885] Compositor[21559]: segfault at 20000008 ip 000055b544f34a30 sp 00007f999b36bee0 error 6 in chrome[55b542641000+6c15000]

BRM added a comment.May 21 2017, 11:40 PM

Yeah, compositor has been consistently segfaulting first, which then causes a myriad of random crashes across the board (discord, chrome, but mostly chrome).

BRM added a comment.May 25 2017, 2:50 PM

I don't know what's been causing this, but it affects all instances of chrome and derivatives like electron based clients (eg: discord).
Another example:

[ 2755.997351] DiscordPTB[1996]: segfault at 81c32200008 ip 00007f56d6c959ad sp 00007fff5fa71910 error 4 in libnode.so[7f56d61fa000+13c1000]
[ 2770.361040] traps: Compositor[2304] trap invalid opcode ip:66b803 sp:7f590f55f5c0 error:0
[ 2770.361042]  in DiscordPTB[400000+3f4f000]
[ 2782.394999] traps: DiscordPTB[2265] trap invalid opcode ip:66b803 sp:7fff7afdb9f0 error:0
[ 2782.395003]  in DiscordPTB[400000+3f4f000]
BRM added a subscriber: ikey.EditedJun 3 2017, 5:08 PM

@ikey Any chance you could look into this?

Bakano added a subscriber: Bakano.EditedOct 27 2017, 12:03 PM

If there's anything I can do to help let me know (logs), please. I've been without Chrome for 3 days now, can't seem to "revert" since the package isn't in repo or cache'd, and

Macro dealwithit: I JUST CAN'T ANYMORE

JMV

lol broken meme :(

BRM added a comment.Oct 27 2017, 1:51 PM

Yeah, it's been getting worse. Something is really broken. Even files segfaults occasionally. Probably glibc.

We haven't changed glibc, so I don't see how you're assuming that. Chrome is the thing that changed and it needs to be dealt with them upstream.
We don't build or provide Chrome directly, its a third party package provided entirely by Google. This is also happening for users on openSUSE, so
its certainly an upstream regression with the sandbox mechanism. Vivaldi are aware of fixes in the Chromium tree to work around the "random"
failure and looking to emergency-port it, so all we can do at this moment is wait for Google to issue a new build.

BRM added a comment.Oct 27 2017, 3:50 PM

Ohhh, good to know. Thanks for the update.

This is the sad thing about the proprietary software. We can't fix it :/

BRM added a comment.Oct 27 2017, 4:05 PM

Can you post the bug report (opensuse's, chromium's or both)? Their bug trackers are a clusterfuck.

BRM closed this task as Resolved.Nov 29 2017, 5:40 PM
BRM claimed this task.

Somewhat resolved. Still have to --disable-gpu but it's far more stable and I'll maybe experience one crashed tab a day, if that.

BRM reopened this task as Open.May 20 2018, 9:00 PM

Never mind. Happens frequently in highly interactive websites like huobi.

BRM added a comment.May 27 2018, 8:53 AM

Launching with --disable-gpu, it still crashes. Appears to be related to gzip.

Cannot exec gzip.
sys_waitpid() for gzip process failed.

Unexpected crash report id length
Failed to get crash dump id.
Report Id:
Cannot exec gzip.
sys_waitpid() for gzip process failed.

Unexpected crash report id length
Failed to get crash dump id.
Report Id:
Cannot exec gzip.
sys_waitpid() for gzip process failed.

Unexpected crash report id length
Failed to get crash dump id.
Report Id:

Solus, 280x, mesa-18.1.

Reinstall gzip

sudo eopkg install --reinstall gzip

In fact, reinstall all broken packages.

sudo eopkg check | grep Broken | awk '{print $4}' | xargs sudo eopkg it --reinstall

BRM added a comment.May 27 2018, 10:10 AM

@sunnyflunk I actually did reinstall gzip after the first time I saw that, and the error persisted. As for broken packages, only yarn was broken apparently.

DataDrake triaged this task as Needs More Info priority.Oct 8 2018, 11:27 AM
DataDrake added a subscriber: DataDrake.

Is this still an issue?

JoshStrobl closed this task as Invalid.Nov 4 2018, 12:16 PM
JoshStrobl added a subscriber: JoshStrobl.

Closing due to lack of response.