Page MenuHomeSolus

Vino not enabled at startup
Closed, ResolvedPublic

Description

Vino is not automatically enabled at startup after configuring screen sharing:

  1. Settings > Sharing > Screen Sharing
  2. Configure and Enable
    1. Open dconf and disabled encryption if VNC client does not support it.
  3. Restart system
  4. Attempting to connect system from VNC client fails

However after running:
/usr/lib64/vino/vino-server

Connecting to system over VNC works.

Event Timeline

jrseliga created this task.Apr 18 2017, 2:13 PM
DataDrake added a subscriber: DataDrake.

Looks like you'll need to enable the system service from terminal:

sudo systemctl enable vino-server
sudo systemctl start vino-server

I'm not entirely sure what G-C-C is doing to enable it, but it's not that.

Running:

sudo systemctl enable vino-server

Does not work:

Failed to execute operation: No such file or directory
loganm added a subscriber: loganm.May 27 2017, 10:37 AM

I can report, the same problem is effecting me.

After enabling screen sharing, there is no service listening on port 5900.

Running sudo systemctl enable vino-server
results in Failed to execute operation: No such file or directory.

Running the vino-server from /usr/lib64/vino/vino-server binds port5900, and screen sharing starts working as expected.

Sounds like we just need to register vino-server with systemd.

Justin added a subscriber: Justin.Jul 26 2017, 4:09 AM

I've just come across this from the reddit thread and confirmed. vino is a user systemd service but still won't start (systemctl --user start vino-server), the error is due to it not automatically detecting which x11 display to use.

A temporary workaround as @loganm mentioned is to start it directly from a terminal. You can also place & at the end then close the terminal using Ctrl+D /usr/lib64/vino/vino-server &

Justin triaged this task as High priority.Jul 26 2017, 4:17 AM

As this is part of ISO, changed priority.

Don't forget, you can also add it as a menu item with alacarte, and then add it as a startup program with Gnome Tweak Tool.

ikey closed this task as Resolved.Nov 26 2017, 5:04 PM
ikey claimed this task.
ikey added a subscriber: ikey.

So yeah this is working on unstable right now, could be a total fluke that I unbroke it with that systemd update a minute ago, but ya. it works.
Please re-open after the sync if this comes back

I think this is re-occuring right now on Solus 4.1

Seems to be occurring on my Solus 4.1 Budgie as well.

This problem still exists.