Page MenuHomeSolus

tlp.service takes over 1.5 seconds to finish
Closed, ResolvedPublic

Description

Seems awfully high from what I've seen. System is a i5-4670, r9 280x, one ssd and one hdd. Solus was installed two days ago and barely touched.

systemd-analyze blame

1.561s tlp.service

Not necessarily a bug but rather the curiosity to know if this could be mitigated somehow.

Event Timeline

BRM created this task.Apr 13 2017, 11:06 PM

Yeah we don't include tlp by default anymore - this is one of the reasons :)

BRM added a comment.Apr 13 2017, 11:19 PM

Will it be disabled automagically for installs using the current iso? Is it safe to disable?

No in the new ISOs we just wont include it anymore. At one point we deprecated it from the repo so it forcibly removed itself from installations.
But despite the facts that tlp is obviously Ungood, people protested. So we undeprecated it.

BRM added a comment.Apr 13 2017, 11:29 PM

Can I disable the service with no repercussions then?

Oh even better just remove the package

sudo eopkg rm tlp

:D

BRM closed this task as Resolved.Apr 13 2017, 11:34 PM
BRM claimed this task.

Thanks! Done!

BRM added a comment.Apr 14 2017, 1:09 AM
desktop@space ~ $ systemd-analyze 
Startup finished in 2.268s (firmware) + 109ms (loader) + 688ms (kernel) + 770ms (initrd) + 1.075s (userspace) = 4.911s
desktop@space ~ $ systemd-analyze blame
           472ms systemd-timesyncd.service
           117ms lightdm.service
           100ms home-desktop-Storage.mount
            80ms systemd-journal-flush.service

Fast as it should be.

jmayniac added a subscriber: jmayniac.EditedApr 14 2017, 1:20 AM

The problem is that no matter how crap TLP is, there is nothing else us laptop users can use to dynamically change power settings right now. Sure, one could probably write a systemD unit or something, but that is beyond me and I think, not the point of Solus. Honestly, one second of my boot time is acceptable to me to have this functionality.

Maybe have a mechanism in the installer to check for a laptop or it's battery and install and enable TLP, otherwise don't install the program on desktops?

this is one of the reasons :)

It's crap. I don't know why people keep defending it. Even in its most limited, controlled form, it's been responsible for about 30 bugs in Solus just by itself.
Whether its disabling internal SSDs on macbooks, breaking brightness controls, or nuking wifi after 10 minutes. Sure, it'll save your battery life. But you'll
want to hop your laptop off the head of the next passerby.

If you want to use tlp then please by all means go ahead. I'm not going to support it as a default option.

I will respectfully disagree and say that I've never experienced any of those issues on the 10 or so laptops I've used it on. This is purely anecdotal evidence of course.

I really don't care if it's default as long as its available until something better comes along.

Thank you for your hard work and have a good day.

It wasn't about agreement or disagreement. It was in Solus, it caused massive headaches. The bugs are here on this tracker.
It's no longer the default, and the option exists in the repo. As and when we've got the time we'll make a very simple, and
very Solus oriented system for laptops.