Page MenuHomeSolus

PhantomJS
Closed, WontfixPublic

Description

Name : PhantomJS
Homepage : http://phantomjs.org/
Open Source : Yes
Source : https://github.com/ariya/phantomjs
Binary Release : https://github.com/ariya/phantomjs/archive/2.1.1.tar.gz

PhantomJS is a headless Web Kit that allows to navigate and interact with a website via JS or direct JS interpreter interaction.
Including this package shouldn't be an issue as the binary release works without issues.

Event Timeline

CTXz created this task.Apr 2 2017, 5:19 PM
JoshStrobl updated the task description. (Show Details)Apr 2 2017, 6:19 PM
JoshStrobl triaged this task as Normal priority.Apr 5 2017, 12:54 PM
JoshStrobl moved this task from Backlog to Accepted For Inclusion on the Package Requests board.
DataDrake added a subscriber: DataDrake.

This presently needs Qt 5.5 and will have to wait until it can use a newer version.

Any updates on that? Seems we're on Qt 5.6 now. I may be wrong though

Seems that PhantomJS is in need of a maintainer.

More on:
https://groups.google.com/forum/#!topic/phantomjs/9aI5d-LDuNE

TL/DR: No need for Phantom since there is Chrome and Firefox headless mode.

JoshStrobl closed this task as Wontfix.Oct 26 2017, 5:09 AM
JoshStrobl claimed this task.
JoshStrobl added a subscriber: JoshStrobl.

Marking as WONTFIX in that case. I've validated that Headless Chrome works currently and successfully listens to the instructed remote debugging port. Shame PhantomJS is no more but at least we have a solution to replace it.

BearzR added a subscriber: BearzR.Dec 15 2017, 11:23 PM

I know you marked this as won't fix, but today when using youtube-dl to download from openload it required this to be installed. I also image that other sites would need it as well.

@BearzR Then you should talk to the youtube-dl developers about using dead tech then :\