Page MenuHomeSolus

DMAR fault – PTE Read access is not set
Closed, ResolvedPublic

Description

Did not use to happen 3 weeks ago. Right before systemd's fschk kicks in.

Relevant dmesg bits:

[    0.021970] DMAR: Host address width 39
[    0.021971] DMAR: DRHD base: 0x000000fed90000 flags: 0x1
[    0.021976] DMAR: dmar0: reg_base_addr fed90000 ver 1:0 cap d2008c20660462 ecap f010da
[    0.021977] DMAR: RMRR base: 0x000000dd82b000 end: 0x000000dd837fff
[    0.021978] DMAR-IR: IOAPIC id 8 under DRHD base  0xfed90000 IOMMU 0
[    0.021979] DMAR-IR: HPET id 0 under DRHD base 0xfed90000
[    0.021980] DMAR-IR: Queued invalidation will be enabled to support x2apic and Intr-remapping.
[    0.022079] DMAR: DRHD: handling fault status reg 2
[    0.022084] DMAR: [DMA Read] Request device [01:00.0] fault addr c0001000 [fault reason 06] PTE Read access is not set
[    0.022151] DMAR-IR: Enabled IRQ remapping in x2apic mode
[    0.022151] x2apic enabled
[    0.022155] Switched APIC routing to cluster x2apic.

CPU is an i5-4670, and vt-d is enabled. iGPU is disabled.

Event Timeline

BRM created this task.Mar 27 2017, 4:01 AM
BRM updated the task description. (Show Details)
BRM updated the task description. (Show Details)Mar 27 2017, 4:05 AM
BRM updated the task description. (Show Details)
BRM updated the task description. (Show Details)
DataDrake renamed this task from DMAR FAULT – PTE READ ACCESS IS NOT SET to DMAR fault – PTE Read access is not set.Mar 27 2017, 10:54 AM

From what I can tell, this isn't harmful to the system. But to be sure, could you provide the terminal output of lspci ? Thanks.

BRM added a comment.Mar 28 2017, 2:13 AM
00:00.0 Host bridge: Intel Corporation Haswell DRAM Controller (rev 06)
00:01.0 PCI bridge: Intel Corporation Haswell PCI Express x16 Controller (rev 06)
00:14.0 USB controller: Intel Corporation Lynx Point USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation Lynx Point MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation Lynx Point USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation Lynx Point HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Lynx Point PCI Express Root Port 1 (rev d4)
00:1c.2 PCI bridge: Intel Corporation Lynx Point PCI Express Root Port 3 (rev d4)
00:1c.3 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d4)
00:1d.0 USB controller: Intel Corporation Lynx Point USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Lynx Point LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Lynx Point 6-Port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation Lynx Point SMBus Controller (rev 04)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Tahiti XT [Radeon HD 7970]
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Tahiti XT HDMI Audio [Radeon HD 7970 Series]
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 0c)
04:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 03)

I can't say I'm surprised. That error message is specifically about your 7970 and as it is a RadeonSI card, they are a bit "special" on Linux. I'll have to do a bit more digging. Thanks!

BRM added a comment.Mar 30 2017, 5:47 PM

@DataDrake Ironically, when I bought my 280x I thought to myself 'surely this 7970ghz rebrand will have great stability under linux due its somewhat old age'.

BRM closed this task as Resolved.Apr 1 2017, 2:21 PM
BRM claimed this task.

@DataDrake Magically went away with last night's batch of updates.

BRM reopened this task as Open.Apr 1 2017, 6:48 PM

Nevermind, it only went way for 3 boots. It's back.

DataDrake removed BRM as the assignee of this task.Apr 10 2017, 3:50 AM

Near as I can tell, this is being caused by a weird interaction between the Intel iommu and your AMD card. It's completely benign so long as you are not try to use passthrough on a physical AMD card to a Virtual Machine. If you aren't using virtualization at all on this machine, you could disable it in the BIOS and these messages should go away.

BRM added a comment.Apr 16 2017, 1:32 PM

I do use virtualization. Would this interfere with trying to use passthrough on my iGPU?

Not as far as I can tell.

BRM closed this task as Resolved.Sep 30 2017, 8:50 PM
BRM claimed this task.