Page MenuHomeSolus

Artha ~ The Open Thesaurus
Closed, DuplicatePublic

Description

Please add Artha to the repository. It was rejected before because it hasn't been updated in awhile but I believe your policy on that has changed.

Homepage
http://artha.sourceforge.net/wiki/index.php/Home

Reason
Artha is a very handy quick dictionary/thesaurus reference tool. It is tremendously helpful in writing. I know of no other thesaurus that can run in the system tray and allows the user to bind hotkeys for quick inquiry on selected text. Providing information beyond definitions and synonyms. All in a simple well-designed interface.

It is Open Source

I have no idea how many people will use this software.

Link to source tarball
http://downloads.sourceforge.net/artha/artha-1.0.3.tar.bz2

Some distributions that package it
Fedora
https://apps.fedoraproject.org/packages/artha
Debian
https://packages.debian.org/search?keywords=artha
Opensuse
https://software.opensuse.org/package/artha

Related Objects

Mentioned Here
T1867: Artha

Event Timeline

I agree that Artha would be a valuable addition, however, I would rather get a small team together, transfer the repository to GitHub and work for a new release.

JoshStrobl closed this task as a duplicate of T1867: Artha.Mar 24 2017, 3:21 PM
Oatwalker added a comment.EditedMar 24 2017, 8:46 PM

Why was it rejected this time?

read just above your question: closed this task as a duplicate of T1867: Artha.

Oatwalker added a comment.EditedMar 24 2017, 8:58 PM

What's the proper way to get a package reconsidered? Since the reason for the last rejection is no longer policy.

Unless there are new arguments, it won't be reconsidered.
Reason for the rejection was given here

Oatwalker added a comment.EditedMar 24 2017, 9:27 PM

It's my understanding from listening to Ikey that the policy has changed. That a package is no longer rejected simply for being unchanged for a few years. If it is shown to still be packaged in at least two other mainstream distributions.

So the policy hasn't changed?

I am not aware of any change.
The package inclusion policy is here

So it’s allowed but at the descretion of the package maintainers. Thanks for taking the time to answer my questions.

I’ll try to compile it myself.

Personally, I think the best would be to wait that the 3rd party repositories are replaced with the new flatpak-based system.
The problem with "dead-on-arrival" (DOA) applications like this one, is the dependencies... they might stop working with newer version of dependencies which would prevent upgrade of other applications which require newer version of the same dependencies. So I understand that Solus team doesn't want to handle this and eventually offer a bad experience to some users (either by not upgrading some software or by adding some in the repositories and removing them some time later because they don't work anymore).
In such case, it's better to refuse them immediately - which is the case of this app.

If my understanding is correct, flatpak could solve this problem as it allows to package an application with its own version of the librarires and run them in a kind of sandbox, so 2 or more applications could run using different versions of the libraries.