Page MenuHomeSolus

julia ErrorException GMP library
Closed, ResolvedPublic

Description

I installed julia today in two updated machines using Solus Budgie and Mate, respectively. Both of them had this issue when initializing julia:

WARNING: Error during initialization of module GMP:
ErrorException("The dynamically loaded GMP library (version 6.1.2 with __gmp_bits_per_limb == 64)
does not correspond to the compile time version (version 5.1.2 with __gmp_bits_per_limb == 64).
Please rebuild Julia.")

I haven't installed julia before in Solus, so I can't say that it's an update-related problem. I hope somenone can test it.

Event Timeline

rodrum created this task.Mar 20 2017, 2:49 PM
JoshStrobl changed the task status from Open to In Progress.Mar 20 2017, 2:56 PM
JoshStrobl claimed this task.
JoshStrobl triaged this task as Normal priority.
JoshStrobl added a project: Software.
JoshStrobl moved this task from Backlog to Package Fixes on the Software board.
JoshStrobl closed this task as Resolved.Mar 20 2017, 3:21 PM

Updated Julia to 0.5.1 and rebuilt gmp.jl so should be using our GMP now.

In unstable repo: https://git.solus-project.com/packages/julia/commit/?id=b2a7f553fc1ff475c51c849fddadf69d4020c74e