Page MenuHomeSolus

WiFi drops soon after boot
Closed, ResolvedPublic

Description

I've noticed consistently that my WiFi connection comes up fine upon boot. About maybe 5 minutes after boot, it drops, although the icon shows it's connected. I have to disconnect and then reconnect, after which it is solid.

Event Timeline

This is almost certainly related to T1406

However, in T1406 he's obviously having continuous issues. Mine is just 5-10 minutes (today) after a boot. I went into journalctl, but there was nothing about why connectivity might have been dropped. This is the first linux system I've used where things are logged to journalctl and not in separate log files. So perhaps there's somewhere else I should be looking or I need to change what is being logged?

What network card do you have?
As this sounds similar (not the same, though) to the issues I have with the RealTek 8821AE.

@cavaughan I linked to my own issue and the issue is actually the same as listed here. I did reread the details of my own task and edit it to make that more clear. As far as logs, I couldn't find anything either.

As my own response to the question @moriel5 asked, my network card is also Realtek and uses the kernel module rtl8188ee. I'm not sure if this is the same as the model number, but lspci said that the card was Realtek Semiconductor Co., Ltd. Device 8179

moriel5 added a comment.EditedMar 10 2017, 1:18 AM

From what I know, the rtl8188ee and the rtl8821ae share the same drivers, so these issues must be connected.
Also possible, is that users of the rtl8723be and rtl8192ee may have these or similar issues, since it would appear that Levono packages their drivers together (for Windows) or they use the same drivers as our network cards.

I am still convinced that this issue is at least in part caused due to the network that the computer is connected to, as I don't recall it happening on my home network. I can't double check this for another week since I'm at university, where my network issue is happening.

I did check using my phone as a hotspot, though. I rebooted my computer, it connected to the hotspot, I played a game for a little bit to waste time until the network should time out, and opened Firefox. Pages still load and I haven't had to disconnect and reconnect the network. Perhaps it is some weird combination of the Realtek drivers and the settings for the network they are connected to?

My university's network uses WPA2-PSK (Personal) security with a passphrase, but also includes a landing page to associate new devices with a particular student's account for bandwidth limiting purposes before the internet can be used on that device. They use their own DNS servers as well. I'm not sure which of these factors, if any, are causing the issue.

I should reiterate that it's only this network card on this network that has the issue; my other computer running Solus doesn't have the issue, and the Realtek card works fine connected to my phone's hotspot.

moriel5 added a comment.EditedMar 15 2017, 7:44 PM

Sorry for not answering sooner, I hadn't had access to a PC the past few days.
I can say without a doubt, that the network has nothing to do with it, as I also can connect without any issues to my phone's hotspot, so it must be solely driver-related.

Additionally, while testing CloudReady (based on ChromiumOS), I had noticed that these issues simply do not exist there, so that could be a point to consider.

I'm not sure I follow the logic: the network connection fails on some networks but not others, therefore the issue has nothing to do with the network? Surely if that were the case you would see the connection drop on all networks? I agree that it's likely a driver issue, but I think the network itself plays a role as well.

Adding a point of data: now that I'm home for spring break, I can confirm that I do not see the issue on my home network.

RE: issues not occurring on CloudReady, I haven't seen the issue on Arch Linux either, so I'm assuming it's a Solus-only issue.

I can add that I recently used my computer on another network and I forgot about this issue and was confused as to why things were not working, then remembered... ah, I have to reconnect again and then it'll be stable.

Also, I never provided this information:
From lspci:
Ethernet controller: Realtek .... RTL8101E/RTL8102E
Network Controller: Intel Centrino Wireless N-2200

moriel5 added a comment.EditedJul 24 2017, 1:10 PM

Apparently, I was mistaken, and the rtl8188ae and rtl8221ae do not necessarily share drivers, but rather the drivers are similar.
And no, this is not a Solus-only issue, as I had seen it on every distro but CloudReady.

From what I had seen (this is unverified), I think that CloudReady also has those issues, however Chromium's network manager apparently does not trigger them, since it doesn't run scans as often(?), and that it runs old versions of the drivers, which in this case are much more stable.

I am going try try helping out as a tester on lwfinger's GitHub repo: https://github.com/lwfinger/rtlwifi_new, to try helping out with these issues (note: I can only directly help out with the rtl8821ae drivers, so others are also welcome to pitch in and help, as this goes back to the mainline Linux kernel, resulting in the fixes arriving to Solus, as well as other distros, such as Ubuntu, Fedora, Arch, and others).

Update: 2.4Ghz works flawlessly on the rtl8821ae with the latest code from the repo, 5Ghz testing will be done soon.
I am expecting the improvements to arrive in the mainline kernel sooner or later.

And once again, I was mistaken, while the rtl8821ae's and the rtl8818ae's drivers are not precisely the same, they are bundled together (along with a few others) on lwfinger's repo.

Update 2: 5Ghz has no disconnections either, however has slower speed (when streaming from YouTube).

Update 3: From wired testing, I can conclude that 2.4Ghz works on the `rtl8821ae without any breaking issues, as the speed difference lies at about 600 from maximum speed on 2.4Ghz to wired speed (~224000Kbps vs. precisely 30013Kbps).

JoshStrobl closed this task as Resolved.Oct 26 2017, 2:27 AM
JoshStrobl claimed this task.
JoshStrobl added a subscriber: JoshStrobl.

Closing. There's been multiple updates to the kernel and drivers since then. You're welcome to validate under Solus 3 and reopen if the issue remains but as you stated "And no, this is not a Solus-only issue, as I had seen it on every distro but CloudReady."

moriel5 added a comment.EditedNov 5 2017, 10:25 AM

I can happily say, that under the latest 4.13.10 and 4.13.11 kernels, the RTL8122AENF is perfectly stable on both 2.4Ghz and 5Ghz, with proper reception (~83-89% on 2.4Ghz and ~71-81% on 5Ghz, from my room (in context, the router is one floor above me, slightly to the side, and our house has thicker than usual concrete walls), and full internet speeds (I'll post the exact results when I'll have the time).

Regarding network speeds (not download speeds), I am getting the full 150Mbps I am supposed to be getting on 2.4Ghz, however I am only getting 200 out of the 433 Mbps I am supposed to be getting on 5Ghz (even at 100% reception, about a meter away from the router) (I did some research, including in the FCC pages, (this turns out to be a 1x1 card)).

And since a few days ago, I had switched the RTL8211AENF with an Intel Wireless-AC3165 (I am planning on getting the Wireless-AC 8265, however, I am first selling this laptop, and getting either a Dell Vostro 3568 (same basic specs, however better components and build quality, and ironically cheaper), (And a Radeon M420) o̶r̶ ̶a̶n̶ ̶H̶P̶ ̶N̶o̶t̶e̶b̶o̶o̶k̶ ̶1̶5̶-̶B̶S̶1̶0̶0̶N̶J̶ ̶(̶s̶l̶i̶g̶h̶t̶l̶y̶ ̶m̶o̶r̶e̶ ̶e̶x̶p̶e̶n̶s̶i̶v̶e̶,̶ ̶b̶u̶t̶ ̶h̶a̶s̶ ̶a̶n̶ ̶8̶t̶h̶ ̶g̶e̶n̶ ̶i̶5̶,̶ ̶a̶n̶d̶ ̶t̶h̶e̶ ̶s̶a̶m̶e̶ ̶R̶a̶d̶e̶o̶n̶ ̶M̶4̶2̶0̶)̶ (scratch that, it doesn't have space for a 2.5" hard drive, and I need my laptop to last for as long as possible, especially with my limited budget), both of which also have the Intel Wireless-AC 3165), however I plan on keeping the RTL8211AENF for testing against new kernel version on Solus (when I have the time for it), I am getting 150 Mbts on 2.4Ghz, as should be, and 433 Mbts on 5Ghz, as should be (I had conducted the tests about an hour ago), however I am getting reduced reception on it, ~67-71% on 2.4Ghz, and ~47-51% on 5Ghz, in the same exact location where I had conducted the above tests with the RTL8211AENF), so in practice, I get 292Mbts on 5Ghz in my room (the 433Mbts is about a meter away from the router, where I get ~82%, opposed to the 100% on the RTL8211AENF in the location).

However, I shall post the current situation with the Intel Wireless-AC 3165 in a separate task.