Page MenuHomeSolus

/ is the default directory if you want to save a file in gedit
Closed, ResolvedPublic

Description

/ is the default directory if you want to save a file in gedit. Is it intended? I thought /home should be the default one.

Event Timeline

Shrug created this task.Mar 8 2017, 7:10 PM
Shrug renamed this task from / is the default directory if you want to save a file in Nautilus to / is the default directory if you want to save a file in gedit.Mar 9 2017, 7:49 AM
Shrug updated the task description. (Show Details)

Sorry, I meant gedit, not Nautilus.

Can't reproduce this.

Last time an issue like this happened for me (on another distro), I had done something to make my user's home directory inaccessible. This could be done by deleting the folder, a separate /home partition not being mounted, bad permissions settings, etc. Is it possible anything like that could be the problem?

Can't reproduce. Please confirm as to whether or not you are using a separate home directory and the ownership / permissions of your home dir.

Went back and tried to reproduce this. Was able to reproduce when trying to save a new file. Existing files default the save directory to the one they are currently located in, as expected. New files default to /.

I'm using a separate home partition with a directory specifically for Solus. Directory permissions: drwxr-xr-x. Owner and group are both michael.

Shrug added a comment.EditedMar 31 2017, 7:36 AM

@JoshStrobl I can't reproduce it now because currently I have no access to the computer on which I installed Solus, but

  • there were no separate home directory created
  • it was happening only when trying to save a new file, like in @Shadow53 's case

FYI, I am also experiencing this. The terminal add on for gedit also opens in the root directory.

JoshStrobl added a comment.EditedApr 19 2017, 1:56 AM

Please validate if this is still an issue as of our GNOME stack upgrade and/or on a new 2017.04.18.0 ISO. Thanks.

This is no longer an issue on my end.

It's still an issue on my end after the latest updates

Please validate if this issue persists on a fully upgraded Solus 3 installation.

@JoshStrobl I can confirm that it is not happening for me. If I see it happen again, I will ping you.

Thanks @tristan957, much appreciated =)

JoshStrobl closed this task as Resolved.Oct 26 2017, 3:50 AM
JoshStrobl claimed this task.